[SunHELP] Changing hard drives SunOS 4.1.1 Sun4c

Brad Walker bwalker at musings.com
Sun Apr 14 19:30:08 CDT 2013

SunOS 4.1.1 only support 32 bit filesystems. Therefore your partition sizes
can't exceed 4GB in size. I would partition this into a 3GB root, 512MB
swap, 1 GB /usr, and 3.5 GB /opt. Or something like this.

Then then "dump | restore xfi -" from the old disk to the new one should
make it work.

But, your problem boils down to a the 32 bit filesystem limit.

-brad w.

On Sun, Apr 14, 2013 at 3:30 PM, Fredric QJ Bleholtz <e5frog at gmail.com>wrote:

> So, have this Sun Sparcstation 2, the frambuffer broke, bought a
> replacement, the PSU broke, bought a replacement, the external drive
> started acting up, took a backup copy with a clone tool on a PC, internal
> drive started going wacky as well, had to turn it on it's side to make it
> work... have swapped the NVRAM as well, hacked with an external battery.
> So, soon there are no original parts left.
> I used the EaseUs hard drive clone tool from a Ultimate Boot CD, got an old
> 2.25GB drive and successfully made a copy that it booted from. Got the
> panic copy of the external drive with the same program, only option at the
> time was an SD-card in a SCSI-card reader and pointing a fan to the
> external hard drive (5.25" huge monster) at a pair of circuits going hot.
> Disks in that size isn't very easy to come buy at reasonable price so when
> a friend offered a 9GB hard drive with a 68 pin connector and a 50 pin
> adapter I tried it out. Copying from the original giant sized drive didn't
> want to work again so I ran the EaseUs program from the UBCD 5.1.1 with the
> SD-card instead. Went fine, no errors.
> After hooking it to the Sparcstation 2 it wasn't accepted, complained about
> the header - seems it wasn't what it was supposed to be, found some tip
> about replacing a missing header and checked the format command but got
> stuck when it asked for cylinders etc, couldn't find any proper information
> about that and I haven't dealt with it since I added hard drives to my
> Amiga in the early 90's.
> So I quit, took a look at the drive in WinHex with the drive hooked to a
> SCSI-card in the PC. The header was emptied out, the previous "SUN1.3G cyl
> 1965 alt 2 hd 17 sec 80 etc etc" wasn't there any more, possibly the format
> command erases that even before you have entered any information?
> The 9GB drive seem to have been found but is there any idea to keep trying
> with that, is it likely it will work?
> How come the 2.25GB drive worked with a binary copy, the header (at least
> was) "SUN1.05 cyl 2036 alt 2 hd 14 sec 72" and wasn't correct either. I
> assumed it used the drive like it had that geometry and simply didn't care
> about the rest of the hard drive.
> I have filled the 9GB drive with $FF and will attempt to write the binary
> data back again, hope it will make a difference.
> I'm not interested in updating stuff, installing other OS or similar, want
> to keep the same data, just swap to functional drives. I only keep this
> computer around so I can access that one program I need old data from from
> time to time.
> I have the data that's going to be on the drive (I assume it's correct as
> it was copied with no errors), just need a compatible drive or the correct
> procedure to put it there.
> Any sane advice about this would be most helpful, these hard drives don't
> hold on forever.
> / Fredric the newcomer.
> --
> __________________________________
> * Fairchild Channel F collector extraordinaire *
> http://channelf.se - The Gallery of Channel F
> _______________________________________________
> SunHELP maillist  -  SunHELP at sunhelp.org
> http://www.sunhelp.org/mailman/listinfo/sunhelp

More information about the SunHELP mailing list