[SunHELP] Sol10 recommended patch-cluster - boot-panic on SunSparc-UltraAX-MP after installation

Michael Karl mk at lexcom-net.de
Tue May 12 10:43:07 CDT 2009


I tried the last days/weeks many things ... nothing was helping.

Last Thursday I got the disaster ... we lost in the afternoon three 
times the power for everything in our house more than 15 minutes.

During the first lost of power the UPSs had worked fine ... but one hour 
later during second lost of power every server had crashed.

On last Friday I 'd made two hard mistakes ... after booting the 
UltraAXmp I had to do a fsck (ok ... on the wrong disk) ... I'd done 
this, but rebooted the first-disk ... ok same error ... fsck on the 
first disk, everything was working ... and then in panic I mad my second 
strange error ... metasync in the wrong way :-( My Last Friday ... 
Murphys Law ... after my 49th birthday on last Thursday.

And now I have to install a fresh Solaris 10, because I have  a 2.9 TB 
Hardware-RAID5 with zfs ... the zfs-filesystem can't be corrupted, 
because I'd made a normal power-shutdown via web-interface after the 
first lost of power.

The actual solaris10-cd's or opensolaris-cd's are not bootable for this 
UltraAXmp ... error as discribed.

So I tried yesterday my old sol10-cd ... first cd is booting well, but 
during installalation I got many read-errors on second cd ... 
installation failed.

Now I'm looking for solaris10-cd-images earlier then 2009 ... but I 
don't find them ... ok ... I'm thinking, I have them on my ZFS-RAID :-(

Any hints ... links ... maybe to an university ... something like that ?

thanks in advance


BTW. It's my home-office ... but I'm out-of-order since January 2007 ... 
I had four operations in the last 16 month ... now I need your help.

Michael Karl schrieb:
> Hello,
> after recommended patch-cluster-installation (with no problems) boot 
> failed now.
> I found a thread via google:
> http://groups.google.com/group/comp.sys.sun.admin/browse_thread/thread/5e7bf4a54622d0ac 
> Same sun, same panic
> but I found no answer to solve this problem.
> Has someone any hints for me ?
> Thanks Michael
> Michael Karl schrieb:
>> Hi all,
>> my way is working. 1 - 7 ... it's easy and fast ... also the way back.
>> Thanks
>> Michael
>> BTW.: Now I have a new problem with recommended patch-cluster ... 
>> I'll make a new post later.
>> Michael Karl schrieb:
>>> Hi all,
>>> thank you for your tips and tricks.
>>> My plan now:
>>> 1. metadetach all submirrors ... so the "mirror-disk" is out of work.
>>> 2. fsck on all partions of the "mirror-disk", because metadetach has 
>>> made them unclean.
>>> 3. mount the / of the "mirror-disk" and edit /etc/vfstab and change 
>>> all entries /dev/md/dsk/dx to /dev/dsk/cxtxdxsx. At last I uncomment 
>>> or delete in the /etc/system the entry
>>> * Begin MDD root info (do not edit)
>>> rootdev:/pseudo/md at 0:0,0,blk
>>> * End MDD root info (do not edit)
>>> 4. I don't make any changes on the "first-disk" (it's still 
>>> working); reboot and boot "mirror-disk" and test it.
>>> 5. If the "mirror-disk" is booting and working well, I reboot the 
>>> system and with starting the "first-disk".
>>> 6. I'll install the recommended patch-cluster ... if this is 
>>> working, I metattach the "mirror-disk"-partitions.
>>> 7. If not, first I have to analyse the errors ... and if I should 
>>> find no error-solutions, I boot the "mirror-disk", have a look on 
>>> the md-devices ... normally all md-devices still exists ... change 
>>> the /etc/vfstab except the root-entry, make metaroot and lockfs ... 
>>> reboot the "mirror-disk" and metattach the "first-disk"-partitions.
>>> BTW. I'm thinking, that I need the way back, because the actual 
>>> Solaris 10 10/08 boot-install-cd let the machine crash with panic 
>>> during the boot-process.
>>> Any comments ?
>>> Thank you all
>>> Michael
>> _______________________________________________
>> SunHELP maillist  -  SunHELP at sunhelp.org
>> http://www.sunhelp.org/mailman/listinfo/sunhelp

More information about the SunHELP mailing list