[SunHELP] NFS--Linux server & Solaris client

Steve Sandau ssandau at gwi.net
Sat Aug 4 15:33:33 CDT 2007

I have tried to figure this one out on my own with copious Googling, but 
to no avail. Maybe there is someone here who has some suggestions. I'll 
try to detail what I have tried so far.

I have a Slackware Linux NFS server (2.4.9 kernel on a dual P166 CPU IBM 
server) that works fine with Solaris 10 and Linux clients.

I recently went back to Solaris 9 on my Ultra2 and am unable to get some 
basic things to work with an NFS mount to the Linux server.

I can mount the share, and run 'ls' on some directories, but not all. 
The directories that produce listings appear to be the ones that have 
short listings. For most directories, 'ls' on the Solaris client hangs 
and eventually gives me a message to the effect that the NFS server is 
not responding but that the client is still trying.

I have tried different versions of the mount command including such 
options as rsize=2048 wsize=2048 proto=tcp vers=3 without changing the 
behavior at all. There is no firewall on either box, and they are on the 
same network with nothing but a 10m hub in between.

Anyone have any ideas? Let me know if I have left anything out.



More information about the SunHELP mailing list