[SunHELP] Opening port 5432 for PostgreSQL

Micah DesJardins micahdj at gmail.com
Mon Jan 23 17:05:59 CST 2006

Hi all,

I've got a workstation running 10 Update 1 (1/06) and the PostgreSQL 8
packages from blastwave.

Locally, I can connect to the database using the built in client
(psql) just fine, but I can't do the same from my Mac OS X machine on
the same subnet.  when I

$nmap -v -P0 -sT localhost

I see:

Discovered open port 5432/tcp open postgres

When I run
$nmap -v P0 -sT x.x.x.x
I get a tremendous number of open ports but not 5432.

If I try
$nmap -v -p5432 -sT x.x.x.x
I get:
5432/tcp closed postgres]

This leads me to believe it's a firewall issue, but when I checked


It was blank (except for the header comments)

My question is, how do I go about opening this port for TCP/IP
traffic? I've looked at
/etc/ipf/ipf.conf (which is blank)

I tried ipf -D to disable it, but the results were the same.  My docs
say ipf is the firewall included.  Am I missing something?

I'm in the process of getting ethereal built, but I'm curious as to
what I might be missing.  I looked at inetadm and ndd but I have the
feeling I'm missing something simple, can anyone out there throw me a

Thanks in advance,


More information about the SunHELP mailing list