[SunHELP] installing U2 without CDROM - help please!

Pitr Milleson pitr256 at milleson.com
Wed Jun 15 12:21:13 CDT 2005


I had this same problem occur on a U60 after the unit was shipped through
the mail. The machine in question had the same issue, where it would start
to load the boot image and then just hang. I had to completely remove and
reinstall the CPU and memory on the planar and then everything magically
started working. I believe the cause was the CPU cards not being fully

Interestingly because the U60 machine otherwise seemed to function at least
at the OBP. Since the U60 is dual proc, my assumption at the time was that
one proc was working from the OBP and the other was not fully seated causing
the issue. Perhaps the same is occurring on your U2. Does it by chance have
dual procs?

I've done a number of net boot installations on Sun hardware so if that
doesn't seem to help, let me know.


-----Original Message-----
From: sunhelp-bounces at sunhelp.org [mailto:sunhelp-bounces at sunhelp.org]On
Behalf Of Steve Tremblett
Sent: Wednesday, June 15, 2005 11:06 AM
To: rescue at sunhelp.org; sunhelp at sunhelp.org
Subject: [SunHELP] installing U2 without CDROM - help please!

I'm currently trying to get ANY OS on a CD-less U2 I picked up but I'm
having no end of frustration.

I've gone through multiple diskless how-to's from Net/Open/FreeBSD but
I have had no success.  The box successfully fetches the loader via
tftp, but nothing else happens.  There is no other network traffic
(checked with tcpdump), and the U2 console just hangs with no info.  I
issue "boot net" and I see a hex number count up to "a000" as it loads
the file but nothing else.  I've handed it loaders from all the BSDs
and even tried to send it a kernel just to see what happened but
nothing.  The server is a U10 running NetBSD.  Has anyone done this
recently?  Are there some gotchas that aren't in the NetBSD diskless
how-to?  (http://www.netbsd.org/Documentation/network/netboot/)

I've also tried hooking up a SunCD4 from my Sparc 5.  The boot ROM
recognizes the drive is present, but "test cdrom" and "boot cdrom"
result in NO drive activity at all.  The test returns to the prompt
immediately and the boot hangs and waits forever.  The drive is set to
ID 6 and I tried with termination on and off.  Can anyone clarify if
this drive will work in a U2?

My eventual goal is to get FreeBSD on the U2 for the SMP support, but
I need to figure out this diskless issue first.  I got my hands on a
Sun PCI SCSI card for my U10 to install on a drive plucked from the U2
but I'm saving that as a last resort.  I'm pretty green at all this so
any and all help is appreciated! :)

SunHELP maillist  -  SunHELP at sunhelp.org

More information about the SunHELP mailing list