[SunHELP] Bad PBR sig

Baharev Ali ali.baharev at gmail.com
Mon Jun 13 19:07:40 CDT 2005

I have spent a lot of time searching for the solution (e.g.: Google; 
Multi-booting Solaris and other operating systems - Mariusz Zynel; 
SUNHelp; etc) but I could not find it.

I have tried to install Solaris 10 from DVD. I have an intel machine 32 
bit. The hdd is the primary master on the IDE channel 0, there is no 
other hdd. On the first partition, there is Win XP already installed (39 
GB). The second partition is for Solaris, approx 36 GB. The third 
partition is a FAT32 for data storing.

Fedora Core 3 was installed previously on the the machine, with the boot 
manager GRUB in the mbr.

The second partition was created by PartitionStar, simply deleting the 
Linux partition and the swap partition, and than creating one, a 82 
Solaris partition. It was strange that i removed the Linux partition and 
it disappeared but there was still an empty line(?) in the PartitionStar.

During installation Solaris 10, the program reported that there is not 
enough space on the hard disk so i had to decrease the Solaris partition 
with 5 MB. It was strange as the machine computed the previous incorrect 
disc space 36241 MB, which was decreased to 36235 (if a remember well to 
the numbers).  Very strange.

Apart from this everything seemed OK during installation.

After the first rebooting, i get "bad PBR sig".

I have a Kanotix LiveCD, and grub is installed on the CD so i can boot 
XP. I have checked with the PartitionStar, the Solaris partition is 
active, it is type BF. (The strange empty line disappeared.)

I also tried to boot Solaris with GRUB, but it reported Error 13: 
Invalid or unsupported executable format, when typing chainloader +1 
(after rootnoverify (hd0,1)).

Could anyone help me?


More information about the SunHELP mailing list