[SunHELP] GCC on solaris

Miguel Cardenas mfcardenas at prodigy.net.mx
Sun Oct 24 20:32:22 CDT 2004

Hello people

As I commented some time ago, the goal to have solaris was to port a 
library... once my whole system was up and running, with gcc and another 
required utilities, tried to compile the library by parts to detect any 
problem and fix it piece by piece...

By now found 2 problems that don't know how to solve them, at least the 

1. when I include <signal.h> there's an error indicating that some structure 
members don't exist etc etc. how can I fix that? I don't have troubles with 
my code, the error appears in signal.h Any suggestion? my library is based on 
signals and threads, by force need it to work... I used gcc downloaded from 
http://www.sunfreeware.com/ not the one included on solaris 9 companion cd, 
maybe some solaris structures required by gcc changed from one version of gcc 
to the more recent at sunfreeware...

2. some source files use the bzero() function, in linux available at 
<string.h> but trying 'man bzero' it appears in <strings.h> (note the 
aditional s)... trying a 'find' of string*.h found two files:


which one is the good one? my system has 'cc' and 'gcc' installed, does it may 


the main fixes I'd being making were some castings that gcc for linux assumed 
naturally and solaris required to be specified...

I've been thinking of a new possibility, to use 'cc' instead 'gcc' but some 
data types are particular to 'gcc' or install from CSW everything, but didn't 
like it 'cos it installs libraries etc in different directories, and most 
applications create its own 'lib' directory inside the application's 
directory, at least the ones I tried...

Thanks for your suggestions,

More information about the SunHELP mailing list