[SunHELP] /home unusable

Kelvin Chu kc at ih.unsw.edu.au
Sun Oct 10 21:35:20 CDT 2004

Was the drive mounted read only somehow?

Miguel Cardenas wrote:

>Hello list
>I was trying to add a user to my solaris box, but useradd fails telling me 
>"Operation not applicable"...
>Tried to create it by hand the home directory with mkdir, but I get the same 
>error... changed to / and 'ls' tells that /home is dr-xr-xr-x, tried to 
>change to drwxr-xr-x by running 'chmod 755 /home' but I get "WARNING: can't 
>change /home'
>How can I change its mode and allow the new user home directory be created 
>inside? simply can't do nothing to '/home'
>Am logged in as root, still have not users.
>I did this:
># groupadd -g 500 reno
># useradd -u 500 -g reno -d /home/reno -s /usr/bin/bash -m reno
>UX: useradd: ERROR: Unable to create the home directory: Operation not 
>#mkdir /home/reno
>mkdir: Failed to make directory "/home/reno": Operation not applicable
># chmod 755 /home
>chmod: WARNING: can't change /home
>SunHELP maillist  -  SunHELP at sunhelp.org

More information about the SunHELP mailing list