[SunHELP] U60 won't boot 64bit Solaris...

Gereon 'Jerry' Stein gereon at sonnenblen.de
Thu Apr 1 03:38:36 CST 2004

That is exactly what I'm worrying about: I did an entirely clean and
fresh install of Solaris 9 (just as I did on an Ultra2 I use in parallel):

The Ultra2 had 64bit as default after the load, the Ultra60 didn't.

Both were tested with the exact same two 501-4849 Rev. 03 CPUs, which
are definitely supported according to Sun.

I did a second load - and a comparison load of Solaris 8 - just to make
sure nothing went unnoticed with the installation (like a file failing
to install or something) - U2 = 64bits, U60 = 32bits. This is really
confusing. Looks like the install routing does not even _attempt_ to
make 64bit the default. The 64bit kernel on the U60 would only appear if
I manually install the respective package (or patch 112233-11 for that
matter). I mean, the U60, including what I put into it, is not that new
a piece of hardware that there should be _any_ support issues with Sol.9.

I am receiving another U60 today, to see whether that will make any
difference. After all, from the hardware side that was the only part I
couldn't swap so far ;)



Peter Stokes wrote:

> Hi
> I thought the 64 bit kernel was the default for > 200Mhz CPU's from a
> clean load?
> Peter
> On Tue, 2004-03-30 at 21:23, Gereon 'Jerry' Stein wrote:
>>I finally bought an Ultra 60 and installed the following hardware:
>>- 1280 Megs of RAM
>>- 2* 501-4849-03 300MHz CPU Module
>>- 2* Seagate Barracuda 50GB SCA disk
>>- Elite 3D UPA graphics board
>>- SunSwift PCI additional I/O Board
>>I was able to install Solaris 9 just fine, also upgrade Firmware of the 
>>box to 3.31, but discovered Solaris 9 would only boot in 32bit mode!
>>Any attempt to "force" it to load 64bit OS leads to:
>>krtld:error during initial load/link phase
>>panic - boot: exitto64 returned from client program
>>I exchanged virtually everything: CPUs, RAM, disks, graphics boards, 
>>I/O-board - tried removing hardware to a minimum setup -> same effect.
>>Following hints I found elsewhere, I even tried _downgrading_ the 
>>firmware again. Needless to say that this didn't make things any better 
>>(or worse, for that matter).
>>Any ideas as to what might be wrong?
>>SunHELP maillist  -  SunHELP at sunhelp.org
> _______________________________________________
> SunHELP maillist  -  SunHELP at sunhelp.org
> http://www.sunhelp.org/mailman/listinfo/sunhelp

More information about the SunHELP mailing list