[rescue] External drives on an X4540

Phil Stracchino phils at caerllewys.net
Fri Oct 18 14:46:27 CDT 2019

So I'm trying to hook up a four-flot external hot-swap SATA6 chassis (PC
Pitstop J0406T) to my X4540, and running into a weird problem.

* So far I have tried two controllers, an LSI 9212-4i4e and an LSI
9207-8e, and two SAS cables, one possibly single-lane and one that I am
assured is multilane.
* With the single-lane cable and either controller, I see only the drive
in the first slot, but I can hot-swap drives in that slot and I see the
disk swaps in cfgadm.
* With the multilane cable and no other changes, I see the FIRST drive
mounted in slot 1, and no other slots, but it seems the SCSI driver for
that controller then locks up and I do not see drive swaps or even
removal, Solaris continues to show that drive present even with the
external chassis powered off and disconnected, and I am unable to shut
down cleanly even via the service processor (stop SYS does not work) and
have to hard power-down.
* It does not seem to matter whether the multilane cable is plugged into
the controller as long as the other end is disconnected.  As soon as I
plug it into the external chassis as well, things go to hell.
* I have not tried the multilane cable on the 9212 controller.  The
vendor (PC Pitstop) has sent me a new internal cable and port multiplier
board for the external chassis and it didn't change any behavior.

Anyone have any suggestions?  Besides swapping back to the 9212-4i4e
controller and trying it with the multilane cable?

  Phil Stracchino
  Babylon Communications
  phils at caerllewys.net
  phil at co.ordinate.org
  Landline: +1.603.293.8485
  Mobile:   +1.603.998.6958

More information about the rescue mailing list