[rescue] Sparcstation LX Restoration & Help

rescue rescue at hawkmountain.net
Tue Nov 26 13:47:05 CST 2019

I hate tantalum caps....  I am also in the arcade hobby, and you have 
to get used to tantalums popping :-).  I've replaced tantalum caps in 
arcade, on 600MP boards, most recently a Qume 5.25" FH 360K floppy.... 
they fail short.... sometimes they blow, which makes it easy to find the 
culprit.... sometimes they just short (and in the case of that floppy 
drive, trip the PC power supplies protections).

BTW, You didn't mention SunOS 4.1 version, but in case you're not 
familiar with SunOS 4 on Classic/LX, they require 4.1.3C or later 
(4.1.3U1, 4.1.3U1 Rev B, and 4.1.4).  It will not work for 4.1.3, 4.1.2, 
or earlier.  And if you boot from CD, or copy data from it, sun4m boot 
partition is partition 3 on the CD.

One of these days I have to dig out my prototype LX.  Sadly the board 
was dead, so it has a standard LX board in it.  It is a bit of an 
oddball, As the top is IPC/IPX, the bottom is LX prototype, and the 
board is now LX production :-).

I have a number of Sun projects I have to get back to, a Sun 1/150U, 
Sun 2/120, and a Sun 486i.  Also have a fair amount of VME stuff, and 
intend to put together a Sun-3/450 (not sure this was ever offered in 
the x50 chassis).

I really would love to find a 4/260 or 3/260 sometime (even if there 
are no boards in it).  Something about those old brown towers I liked 

Good luck getting the LX installed !

-- Curt

On 2019-11-25 11:22, Bill D wrote:
> Twenty years ago, I retired my old Sparcstation LX that had served me 
> well
> for a number of years.  When I packed it up, it was still working
> perfectly.  After successfully bringing an old Sun 3/80 back to life 
> a
> couple of months ago, I thought it would be a good time to do the 
> same for
> the LX.  I figured things would go smoothly since the machine was 
> working
> when I packed it up.  I couldn't have been more wrong.
> For starters, the machine wouldn't power on.  I disassembled the 
> machine
> and removed the power supply and discovered something inside it had 
> leaked
> -- probably a capacitor although I could not find a bad capacitor by
> inspection.  Taking the lazy way out, I ordered a replacement power
> supply.  A week or so later I had the machine reassembled with the 
> new
> power supply and powered it on with some trepidation.  Everything 
> sounded
> normal for a few seconds and I was about to breathe a sigh of relief 
> when
> the power supply started to make a clicking sound.  I immediately 
> powered
> it off but that was when an acrid smell hit my nose.  Damn, I 
> thought, they
> must have sent me a bad power supply.
> I disassembled the computer yet again and removed the power supply 
> (the
> smell was really bad when I opened the computer).  I hooked it up to 
> a hard
> drive and powered it on just to confirm it was bad but it came up 
> fine and
> the hard drive spun up just as you would expect.  Could the problem 
> have
> been with the computer itself?  I looked over the motherboard and 
> sure
> enough one of the many tantalum capacitors that Sun had unwisely 
> chosen to
> use on this board had exploded -- the source of the awful smell.  It 
> turned
> out to be a 47 uF SMT tantalum with a 16 Volt rating.
> A few days later my Mouser order arrived and I removed the two 47 uF
> tantalums on the motherboard and replaced them with modern 25 Volt 
> rated
> parts.  While I was making the Mouser order, I ordered a 48T08 
> chip as well since I was pretty sure mine would have long since died. 
> It
> went in right after the tantalums were replaced.  Reassembling 
> everything,
> I once again powered everything on while holding my breath.  This 
> time the
> computer stayed on and didn't make any funny noises!  I let out a 
> breath
> and connected the terminal to the serial port since I don't yet have 
> a Sun
> compatible monitor to hook up to it.
> After successfully running all of the selftests, it came up in 
> diagnostic
> mode since the NVRAM was cleared.  I followed the nice FAQ at
> http://lib.ru/TXT/faqsunnvram.txt in order to restore the IDPROM 
> portion of
> the RAM and was able to boot into NetBSD 1.9, the OS that was running 
> so
> many years ago when I retired the machine.
> NetBSD is a great OS, but as this is a vintage computer, I'm much 
> more
> interested in running the original SunOS 4.1 on it.  I happened to 
> have
> downloaded two different versions of the CDROM image for it in ISO 
> format.
> I 3D printed a mount for my SCSI2SD card, mounted it, and installed 
> the
> assembly into the LX with little difficulty.  Removing the floppy 
> cover
> allowed me to run a USB cable temporarily into the LX to access the 
> while I get everything working.
> Here's where I ran into a little trouble.  I used the SCSI2SD utility 
> to
> create two different SCSI disks on my SD card.  The disks show up 
> just fine
> on my Linux computer as sdb and sdc.  I was able to use gparted to 
> create a
> supposedly sun-compatible disk label.  From there, I used dd to 
> transfer
> the CDROM ISO image onto sdb1.  Running lsblk on Linux I see:
> sdb                       8:16   0     2G  0 disk
> b
bsdb1                    8:17   0 313.8M  0 part  
> /media/dorsey/Volume
> 14
> b
bsdb2                    8:18   0  16.3M  0 part  
> /media/dorsey/Volume 1
> b
bsdb3                    8:19   0  16.3M  0 part
> b
bsdb4                    8:20   0  16.3M  0 part  
> /media/dorsey/Volume
> 11
> b
bsdb5                    8:21   0  16.3M  0 part
> bbsdb6                    8:22   0  16.3M  0 part
> Examining the mounted volumes, I see what appear to be SunOS install 
> media
> files on reasonable-looking paths.  So I run probe-scsi on the LX and 
> see
> the two SCSI volumes I setup earlier with the SCSI2SD utility:
> ok probe-scsi
> Target 0
>   Unit 0   Device type 20  Qualifier  20     codesrc scsi2sd         
> 6.0
>   Unit 1   Device type 20  Qualifier  20     codesrc scsi2sd         
> 6.0
> Target 3
>   Unit 0   Device type 20  Qualifier  20     codesrc scsi2sd         
> 6.0
>   Unit 1   Device type 20  Qualifier  20     codesrc scsi2sd         
> 6.0
> However, all my attempts to boot from either disk fail with the same 
> error
> message:
> ok boot disk0
> Boot device: /iommu/sbus/espdma at 4,8400000/esp at 4,8800000/sd at 0,0   File 
> and
> args:
> Bad magic number in disk label
> Can't open disk label package
> Can't open boot device
> So either gparted lies when it says it makes a Sun-compatible disk 
> label or
> else the label is somehow being corrupted when I dd the CDROM image 
> onto
> the disk when it's mounted under Linux.
> My next steps are to remove the SCSI2SD from the LX, mount it into my 
> Sun
> 3/80, and properly label it.  Maybe at that point I will be able to 
> move it
> back to the LX and get it to boot.  If anyone has any other 
> suggestions,
> I'd be happy to hear them.
> - Bill
> _______________________________________________
> rescue list - http://www.sunhelp.org/mailman/listinfo/rescue

More information about the rescue mailing list