[rescue] Sun 3/110 using SCSI2SD -- What was needed

Earl Baugh earl at baugh.org
Tue Mar 26 14:50:50 CDT 2019

I finally got my Sun 3/110 to recognize and boot from a SCSI2SD v5.0
card.  I don't know exactly what was the problem, but I do have some
First, details -- I'm using the 4.8.01 firmware on the card.  Second,
I'm using a 16GB card (but that's just because the image I got from
Walter B. was
for a card that size).... I don't have any reason to believe a
different sized card would matter.   Third, I'm using a Sun SCSI card
I did also try two different Sun 3/110 CPU boards.  One with a 2.3
PROM and one with a 2.6 PROM.  Didn't change anything.

Things I tried :  I had 4 external 3rd party "shoeboxes" and 3
additional cable harnesses (harnesses from Sun and 3rd party boxes)
to try
(shoebox wise, not counting the big Sun-2/3 shoeboxes that I
ultimately didn't try, I had 2 which were Sun 3 vintage... one that I
was perhaps a Mac or other more modern system..maybe it was an
external tape, not 100% sure.... and a trusty 411 enclosure).

Initially I tried the "Mac" shoebox, since it's the most compact one.
Before I tried it, I swapped out the "smaller" ended harness
...i.e. similar to the 411 chassis.. to one that matched the end on
the Sun 3 (3 rows of pins, the big monster end...but not centronics
I had three harnesses that I "thought" (and still think) were working
when taken out of service.   Ultimately none of those worked.
I also tried 2 different cables and both CPU boards.  All the
behaviors were identical (which helped me eliminate some variables)

The other two 3rd party shoeboxes both apparently have non-functioning
power supplies (it seems I've got a lot of problems with power
supplies right now :-) ) so those didn't work either.

I tried with the terminators in and out (on the SCSI2SD boards....the
4.0 has resistor packs) and used 4 different terminators I have
(3 generic, 1 Sun branded... one that I'm pretty sure it powered and
active...had a LED in it... which did light up...this isn't the small
size silver terminator from Sun, but a 3-row-of-pins one).

So, I finally tried the 411 chassis, and utilized a cable with the
3-rows-of-pins end on one end and the small SCSI end on the other
(I have two cables like this, one Sun branded, one third party...both
of which I've used in the past as well...)   That was what finally

So, after that, I put the original cable harness (with the two small
ends) back in the Mac shoebox and it works as well.  So it doesn't
to have been power supply based, it seems to have been cable based.
Length wise, I was well under what I thought would be a "long"
length -- definitely less than 4 feet total...  The 411 has a ferrite
bead on the cable, but the harness I replaced does not.   What was
interesting is that both shoeboxes work without terminators on them.
The cable between the 3/110 and the shoebox doesn't matter either.

So, I'm suspecting the smaller end cables with the metal covers change
the signaling or error rates... or something.   That's at least my
current guess.

Also, in the middle of all of this, I did disable all but the boot
partition on the SCIS2SD.  And enabled and disabled the "Enable Unit
Attention" flag.
I also tried toggling these afterwards.  They don't change the working
behavior (nor could I tie them to any difference in the failure

Error wise, I did see a number of different errors.

I got :

"Waiting for Disk to spin up..." :  But believe this was related to
the machine not seeing the SCSI device (or at least the ID I was
A somewhat immediate > prompt (and I did try a lot of different
IDs...0-7 and I did reference this :
http://www.netbsd.org/ports/sun3/faq.html#boot-devices to see what
else might work)
dma never completed :  Not sure what this caused this.
No label found, attempting to boot anyway.b
 : This made me think I
might be close, but didn't ever change anything.

Also, I never had to re-write the SD card.  That apparently I had
right from the beginning... so that wasn't the cause of the label
error at least.

So, at this point, I can boot the 3/110.  I have to do some file
system sorting (the ID I currently have the partition set to doesn't
match what
it came from, so it's not able to finish mounting and come up
correctly...)  and then I'm going to try to get Sun OS 3.5 loaded on
this.  That's
what I want to have as a "demo" OS for this box.  My first Sun machine
was a 3/110 and started with 3.2.... but 3.5 was definitely the most
of the 3.X vintage.   Once I have that sorted, I'll be on to working
on my 2/120...


More information about the rescue mailing list