[rescue]   Trying to get Cadmus 9200 running (serial console trouble)

Mike Spooner mike.spooner.ux at gmail.com
Mon Feb 4 10:37:59 CST 2019

As well as flow-control, you need to worry about handshaking, ie: the
Cadmus might want to see DCD and/or DSR set on it's end of the serial
connection. If so that usually requires eg: tying the PC-end DTR signal
to the Cadmus-end DCD/DSR (and vice versa is also a good idea) and
isolating each ends' DCD, DSR and DTR from the same pins at the other

I'd be strongly tempted to probe that black cable to see *exactly* how it
is wired. Assuming DB25 plugs, probe each PC-end pin 1-8+20 against
*every* pin 1-8+20 at the other end.

Which raises the possibility that swapping the cable round the other way
is worth a shot, too!

-- Mike Spooner

--------- Original Message ---------
From: Meelis Roos
To: rescue at sunhelp.org
Date: Sun Feb 03 14:58:49 GMT+00:00 2019
Subject: [rescue] Trying to get Cadmus 9200 running (serial console
Some time ago (last year? or 2017?) I wrote about rescue of 5 sets of
Cadmus 9200 computers. Now I finally got around to sorting them out to
what to leave for myself and what to send out to those in the queue.

Yesterday I dug them out.

The sets all seem to be Cadmus 9230 (some parts are from 1987, some from
Cadmus 2800 main box with QBUS cage and no storage and Cadmus 2804-62
storage box
with 65M SMD disk and 16M QIC tape drive (4 boxes have tape drives, one
misses the
tape drive). All main boxes have MC68010L10 CPU, 512M RAM board (directly
to the CPU board), Emulex SMD disk controller (4-wide), 8-port serial mux
(4-wide) and a 2-wide tape controller card, 3 also have parallel port
card (4-wide)
with MC68000-10 CPU on it.

I happily found that there is virtually no dust inside to clean before
plugging in,
and tried to get some output. Just from the main box, no storage
attached. After two
days of trying and reading manuals, I still have no output at all.

The two boxes I used most have three front panel lights and they are on
one lamp is out on one of the boxes but I know the lamp should be on by
swapping the
lamp panels around). The lamps are "RUN", "LTC" (line to clock) and INIT
and they
should be on normally, according to the manual. So the box thinks it is
somewhat alive.
If I remove some QBUS boards, the lamps still light on powerup, except
when I remove
the CPU board (then RUN goes off, as would be expected).

I tried 3 different cables to two PC-s (one Dell D600 with native serial,
one a later
Thinkpad with pl2303-based USB-serial adapter). Tried with and without a
null modem
adapter with all the cables to be sure that I have at least one correct
9600-8N1 as the manual says, and tried both hardware flow control and no
flow control
(by the manual, most ports should have no hardware flow control lines
connected, only
console and another port have it, no explicit mention of whether the
console port
should have hardware flow control).

Reseating all the QBUS cards did not change anything.

With one unknown black cable and no null modem adapter, I got some
strangeness: there
is partial echo back of what I type, but that is garbled (about 1 out of
3 characters
is the same, 2 are garbage that is different for each character).
Interesting part is
that I only get echo for 4 last serial ports (including console on 8) but
no echo on
first 4 serial ports. Might that be some strange pinout of the black
cable that is
somehow activated by remote port handshake?

Does anyone have any ideas how to continue? I want to get the systems up
to the point
where I can at least see which hard disks might still be working (for

Meelis Roos
rescue list - http://www.sunhelp.org/mailman/listinfo/rescue

More information about the rescue mailing list