[rescue] Trying to get Cadmus 9200 running

rescue.pkoch at dfgh.net rescue.pkoch at dfgh.net
Sat Aug 10 13:59:11 CDT 2019

Dear Melis Roos:

for the first time this year I have red the rescue list and noticed your
problems with your Cadmus box.

In 2016 I tried to revive one of my Cadmus boxes with no success.
I documented what I did on a blog at www.pcs-cadmus.de. But the
last entry is from 2016 and I did not have any time for this project
in the meantime.

My main problem in 2016 were the missing serial cards. They are
named MUX-KE and the MUX-KE documentation mentions that
these card emulate a DLV11-J board. So I got a DEC M8043 board
but the jumper positions on a M8043 are different from the jumper
positions needed in a Cadmus box.

So I would very much appreciate a picture of a real Cadmus
DLV11-J board so I can compare the jumper positions.

It's more then 30 years ago that I worked with those Cadmus boxes.
But I remember that immediately after reset the boot-loader
sent out the Message "Minitor" on every serial line. The boot-loader
then waited for the first serial line that returned a single keypress
and that serial line became the console.

Also the serial lines had a mode called "Auto-Echo-Operation".
If enabled every received character was returned in hardware. I
don't remeber wether this mode was enabled by jumper-Setting
or by software-configuration.

Another thing: You mention that your serial card is 4-wide with
8 ports. This is not a MUX-KE (or DLV11-J) but a MUX-KE8
which is totally different hardware. I'm 99,9% sure that these
8-port card are not supported by the boot-loader. They were
configured by the kernel. Unfortunately I don't have
documentation for a MUX-KE8 board. Do you have any docs
that are not yet on my website?

And one final thing: Your CP UnfortunU-box has three lamps and one
key-lock. After power-on you must wait a couple of seconds
and then press the reset-button (the green lamp). The key-lock
will disable all buttons in one of its positions so make
sure it's in the correct position.


PS: Your RAM board does not have 512M but 512K only :-)

Am So., 3. Feb. 2019 um 15:58 Uhr schrieb Meelis Roos <mroos at linux.ee>:
> Some time ago (last year? or 2017?) I wrote about rescue of 5 sets of 2-box
> Cadmus 9200 computers. Now I finally got around to sorting them out to
> what to leave for myself and what to send out to those in the queue.
> Yesterday I dug them out.
> The sets all seem to be Cadmus 9230 (some parts are from 1987, some from
> Cadmus 2800 main box with QBUS cage and no storage and Cadmus 2804-62
storage box
> with 65M SMD disk and 16M QIC tape drive (4 boxes have tape drives, one
misses the
> tape drive). All main boxes have MC68010L10 CPU, 512M RAM board (directly
> to the CPU board), Emulex SMD disk controller (4-wide), 8-port serial mux
> (4-wide) and a 2-wide tape controller card, 3 also have parallel port card
> with MC68000-10 CPU on it.
> I happily found that there is virtually no dust inside to clean before
plugging in,
> and tried to get some output. Just from the main box, no storage attached.
After two
> days of trying and reading manuals, I still have no output at all.
> The two boxes I used most have three front panel lights and they are on
> one lamp is out on one of the boxes but I know the lamp should be on by
swapping the
> lamp panels around). The lamps are "RUN", "LTC" (line to clock) and INIT and
> should be on normally, according to the manual. So the box thinks it is
somewhat alive.
> If I remove some QBUS boards, the lamps still light on powerup, except when
I remove
> the CPU board (then RUN goes off, as would be expected).
> I tried 3 different cables to two PC-s (one Dell D600 with native serial,
one a later
> Thinkpad with pl2303-based USB-serial adapter). Tried with and without a
null modem
> adapter with all the cables to be sure that I have at least one correct
> 9600-8N1 as the manual says, and tried both hardware flow control and no
flow control
> (by the manual, most ports should have no hardware flow control lines
connected, only
> console and another port have it, no explicit mention of whether the console
> should have hardware flow control).
> Reseating all the QBUS cards did not change anything.
> With one unknown black cable and no null modem adapter, I got some
strangeness: there
> is partial echo back of what I type, but that is garbled (about 1 out of 3
> is the same, 2 are garbage that is different for each character).
Interesting part is
> that I only get echo for 4 last serial ports (including console on 8) but no
echo on
> first 4 serial ports. Might that be some strange pinout of the black cable
that is
> somehow activated by remote port handshake?
> Does anyone have any ideas how to continue? I want to get the systems up to
the point
> where I can at least see which hard disks might still be working (for
> --
> Meelis Roos
> _______________________________________________
> rescue list - http://www.sunhelp.org/mailman/listinfo/rescue

Dr. Peter Koch EDV-Dienstleistungen UG (haftungsbeschrC$nkt)
Irisstrasse 45, 47249 Duisburg
Amtsgericht Duisburg, HRB20847
GeschC$ftsfC<hrer Dr. P. Koch

More information about the rescue mailing list