[rescue] ISO burning for Solaris booting

Peter Stokes peter at ashlyn.co.uk
Mon Oct 9 15:51:09 CDT 2017

Hi Earl

DVD from V120 should work fine.

Odd you mention the Mac. I had issues creating ISOs from DVDs on it, when I
then wrote them to DVD they would just not work, had to use a Virtualbox
Windows session to read them. However all the ISOs I have written on it have
worked fine.


Sent from my iPad

> On 9 Oct 2017, at 21:41, Earl Baugh <earl at baugh.org> wrote:
> FYI -- On my V120 I'm still having issues getting ISOs to build a bootable
> DVD.
> Tried burning two different ways on my Mac and tried two different drives
> in the machine.
> No joy so far.   Following up on the Sun Enterprise 3500 thread about
> having problems booting,
> I'm wondering how others have gotten ISOs burnt that boot well.     I don't
> have access to another
> drive for the box... I do have two more DVD burners I'm going to try (but
> those two require I get another
> machine re-constructed and booting).
> Does the size of the blank DVD matter?
> I'm going to try Mike Spooner's suggestions (quoted below) but wanted to
> get feedback, I'm assuming booting a V120 class machine from DVD isn't an
> issue, correct?
> Earl
> On older Solaris releases, "short read" errors can indicate trying to boot
>> off the wrong "soft partition"
>> of the CD/DVD. Not sure if that still applies to Solaris 10 ie: do the S10
>> DVDs still use a "pretend HDD" layout? If so, trying the following
>> alternative boot commands, one at a time, may help:
>>      ok boot cdrom:a
>>      ok boot cdrom:b
>>      ok boot cdrom:c
>>      ok boot cdrom:d
>>      ok boot cdrom:e
>>      ok boot cdrom:f
>>      ok boot cdrom:g
>>      ok boot cdrom:h
>> If that does not get you going, it would be worth checking that the NVRAM
>> settings (device-aliases etc) haven't been messed with by previous owner:
>> posting the output of the OpenBOOT "devalias" command to this list might
>> useful.
>> The other thing to watch out for on the EXX00 systems is the DVD drive
>> itself - some of the Toshiba SCSI DVD drives shipped by Sun with the EXX00
>> systems are incapable of *booting* from DVD media more than 3.5Gb full,
>> allegedly due to firmware bugs in the drive. I can't remember which
>> specific Toshiba models were effected, but a net-search will probably
>> reveal it.
>> I too have had occasional problems with home-burned Solaris 9 and 10 DVD
>> discs (which I have not had with other Solarii, going all the way back to
>> the Solaris 2.2 CDs). Oddly, only the SPARC edition seems troublesome.
>> at slowest speed your writer can manage (yes, 1X if possible), and use the
>> highest quality media you can reasonably afford, and if the first doesn't
>> fly, burn another one.
> _______________________________________________
> rescue list - http://www.sunhelp.org/mailman/listinfo/rescue

More information about the rescue mailing list