[rescue] newest rescue (failure/success/failure)

Walter Belgers walter+rescue at belgers.com
Sat Feb 13 09:24:48 CST 2016

Hi all,

Just a short update on the 3/470.

I have not been able to get the graphics board to work, despite the contact
spray and trying to get the connectors to fit well. Even though $150 for a new
framebuffer might be cheap, it is not something I am willing to pay.

I have done something else though. The boot proms were version 2.9.3 and
version 3.0 is available from sun3arc.org. So I borrowed an EPROM programmer,
spent half a day getting to understand how to program EPROMs and about all
kinds of obscure formats for storing images. But it worked:

Sun Workstation, Model Sun-3/400 Series.
ROM Rev 3.0, 48MB memory installed, Serial #1840.
Ethernet address 8:0:20:6:E7:72, Host ID 41000730.

I also made an image of the old EPROMs and sent them to Heiko Krupp of
sun3arc.org. (He already mailed me he is going to put them online.)

I should now be able to boot from CD-ROM. I was planning on installing NetBSD
to have a bit more modern OS on there. But of course, why make a CD-ROM if I
have network?

First I tried to write the NetBSD miniroot to the swap partition and boot from
there (I could use the running OS for it). All I get is an exeception though:

sun3 # dd if=miniroot.fs of=/dev/rsd0b obs=32k
12288+0 records in
192+0 records out
sun3 # sync
sun3 # sync
sun3 # sync
sun3 #
Abort at 0xF8004CAC.
> b sd(0,0,1) -s
Boot: sd(0,0,1) -s

Exception 0x2C at 0x00004000.

I then tried to boot over the network. I set up mountd, nfsd, rpcbind,
bootparamd, rarpd, inetd/tftpd and put all the files in the correct position
(most importantly the sun3x ramdisk kernel as netbsd).

>b ie() -s
Boot: ie(0,0,0) -s
Using IP Address = 0A010058
Booting from tftp server at = 0A010001
Downloaded 23756 bytes from tftp server.

>> NetBSD/sun3 netboot [1.13]
Using IP Address = 0A010058
netboot: trying netbsd
open netbsd: Unknown error: code 60

At this moment, it hangs. It is talking to the server via UDP port 111
(portmapper) and just after that, it tries to connect to the same server on
UDP port 0 (!). I have on clue what is going on here.

A while later I read something about the swap space needing to be in the first
1GB of the disk. Just as an experiment, I tried to put the miniroot on the
second disk and boot from there. I was happy when I saw the kernel being
loaded but shortly after I got a panic. Sigh. At this moment I have had it
with the beast and stick with SunOS 4.1.1 for the moment.


>b sd(0,10,1) -s
Boot: sd(0,10,1) -s
>> NetBSD/sun3 ufsboot [1.13]
ufsboot: trying netbsd
open netbsd: No such file or directory
ufsboot: trying netbsd.old
open netbsd.old: No such file or directory
ufsboot: trying netbsd.sun3x
1574372+74836 [148544+138212]=0x1d8e70
starting program at 0x4000
console is ttya
Copyright (c) 1996, 1997, 1998, 1999, 2000, 2001, 2002, 2003, 2004, 2005,
    2006, 2007, 2008, 2009, 2010, 2011, 2012, 2013, 2014, 2015
    The NetBSD Foundation, Inc.  All rights reserved.
Copyright (c) 1982, 1986, 1989, 1991, 1993
    The Regents of the University of California.  All rights reserved.

NetBSD 7.0 (INSTALL3X.201509250726Z)
Model: sun3x 470
fpu: mc68882
total memory = 49152 KB
avail memory = 46600 KB
mainbus0 (root)
obio0 at mainbus0
iommu0 at obio0 addr 0x60000000
memerr0 at obio0 addr 0x61001000 ipl 7: (ECC memory)
intreg0 at obio0 addr 0x61001400
zsc0 at obio0 addr 0x62000000 ipl 6: (softpri 3)
kbd0 at zsc0 channel 0: baud rate 1200
zsc0:  channel 1 not configured
zsc1 at obio0 addr 0x62002000 ipl 6: (softpri 3)
zstty0 at zsc1 channel 0 (console i/o)
zstty1 at zsc1 channel 1
eeprom0 at obio0 addr 0x64000000
oclock0 at obio0 addr 0x64002000 ipl 5: intersil7170
ie0 at obio0 addr 0x65000000 ipl 3: macaddr 08:00:20:06:e7:72
vme0 at mainbus0: (A16/D16)
vme1 at mainbus0: (A16/D32)
vme2 at mainbus0: (A24/D16)
si0 at vme2 addr 0x200000 ipl 2 vect 0x40: options=0xf
trap type=0x0, code=0x72d, v=0xfb3fc018
pid = 0, lid = 1, pc = F80A7DEA, ps = 2504, sfc = 1, dfc = 1
             0        1        2        3        4        5        6        7
dreg: 00000040 F80A7A1A F82D0480 F819BE34 F813328C F82D061C F813328C 00000002
areg: 00000040 F8184FF0 FB3FC000 F82DE000 F8114C80 F817CA9C F819BCE8 F7FFFFFC

Kernel stack (F819BBA8):
19BBA8: F80D5246 F819BC3C 00000080 F82D0480 F819BE34 F813328C F82D061C
19BBC8: 00000002 FB3FC000 F82DE000 F8114C80 F817CA9C 00000000 F819BC68
19BBE8: 00000000 00000000 F8268240 00000001 00000000 00000000 00000000
19BC08: 00000000 00000000 00000000 00000000 00000000 00000000 00000000
19BC28: F80040E6 F819BC3C 00000000 0000072D FB3FC018 00000040 F80A7A1A
19BC48: F819BE34 F813328C F82D061C F813328C 00000002 00000040 F8184FF0
19BC68: F82DE000 F8114C80 F817CA9C F819BCE8 F7FFFFFC 00000000 2504F80A
19BC88: 36EE072D 49F9F813 FB3FC018 00000A00 FB3F0000 48780A00 F80A7DF2
19BCA8: F80A7DEE FB3FC000 0A000DB0 000FF53E FB3F0000 F80BA6C0 00000038
19BCC8: 80200000 00000A00 00000000 00000000 F819BCE0 F82DE000 F819BE34
19BCE8: F819BD08 F80A824E F82DE000 F82D0600 F82D0480 F817CCAC 00000000
19BD08: F819BD3C F80AE350 F82D0600 F82D0480 F819BE34 F82D0600 F80ACFB8
19BD28: F80ADB98 F817CA9C F819BE34 F8134C7C F8134A44 F819BD58 F80AE4BC
19BD48: F817CA9C 00000000 F819BE34 F80050AC F819BD7C F8005238 F82D0600
19BD68: F819BE34 F80050AC F817CA9C F819BDD0 F818E8A0 F819BD9C F80ADBBE
19BD88: F817CA9C 00000000 F819BE34 F82D0600 F817CA9C F819BDE8 F80ADD14
panic: Bus error

Abort at 0xF80BE600.

More information about the rescue mailing list