[rescue] newest rescue (failure/success/failure)

JP Hindin jplist2008 at kiwigeek.com
Tue Feb 9 10:41:57 CST 2016

Hey Walter;

I'm late to the party - blizzard weather here in Iowa - and a lot of my 
points have been mentioned already, however I started 'collecting' 
with a pair of 4/470s so I know _exactly_ what you're seeing.

My method to success was:
Spray the bus contacts with a CRC electrical contact cleaner.
Firmly seat all cards (I tended to slot them in almost all the way, and
then kind of slam them that last two inches... I was only in my teens and
a little rough then).

Finally: I would power the unit on and just _leave_ it running its
infinite memory tests, ignoring all of it's errors. After 30-60 minutes of
running I'd do a reset to the CPU and it would come up just fine.

These are machines that aren't designed to be powered down, so I think
having it warm and cozy seems to do wonders for their reliability.

  - JP

On Sat, 6 Feb 2016, Walter Belgers wrote:

> So I spent a few hours on the 3/470.
> First a visual inspection of the boards. I took out all board and found a
> small component on the floor. Oops! But the component was clearly not an
> eighties component, so it must have fallen out of another system. The boards
> looked fine (a few bent pins but nothing serious). I replaced the battery on
> the CPU board. Using documentation, I figured out which board to put where.
> Slot 1 already held a memory board, slot 2/3/4/5/6 were empty and the rest had
> fillers. I put the remaining memory board in slot 2, the CPU in 4/5 and SCSI
> in 6. This matched the backplane jumpers. Given the number of filler plates
> that came with it, no boards appear to be missing.
> I hooked up a serial console and powered up in diag mode.
> Here is what I got:
> Pegasus Boot PROM Selftest
> [..]
> IOC Random Data Block Read (Central Cache on) Test {pass 0x00000001}
> <P4 Lego Color Video board [00000060] detected>
> P4 Overlay Frame Buffer Write/Write/Read Test {pass 0x00000001}
> Unexpected bus error, address=50800000, a5=50800000
> Unexpected bus error, address=50800000, a5=50800004
> Unexpected bus error, address=50800004, a5=50800008
> The LEDs were 1010111.
> This kept going. I expected a memory board problem and tried to start it with
> only one memory board (and tried both) to no avail. Since the error occured
> just after probing the P4 board, I then removed the frame buffer and tried
> again. Lo and behold:
> Sun Workstation, Model Sun-3/400 Series.
> ROM Rev 2.9.3, 32MB memory installed, Serial #1840.
> Ethernet address 8:0:20:6:E7:72, Host ID 41000730.
> Success! The Dataram board appears to hold 24MB RAM, nice!
> I did find an old memory board lying around and tried to put it in slot 3.
> Sun Workstation, Model Sun-3/400 Series.
> ROM Rev 2.9.3, 40MB memory installed, Serial #1840.
> Ethernet address 8:0:20:6:E7:72, Host ID 41000730.
> \o/
> Although there are two SCSI drives in the machine, it wanted to netboot. I
> cannot remember the commands to find discs (this is pre probe-scsi). But first
> I decided to check the P4 board and see if I could get it to work, too. I took
> out all ICs that were in sockets and reseated them. Then I put it back on the
> CPU board. Now I got, very early in the boot process:
> Memory Write/Write/Read Test {pass 0x00000001}
> addr 0x00000000: exp 0x00000000, obs 0x10000000
> The LEDs are 0010001
> I took out the P4 board, but the error remains. I took out memory board 3 and
> 2, but the error remains. I reseated the CPU board but the error remains.
> Aargh, what is happening? I cannot get it to work any more :(
> When it is giving the error, I can press ESC and the memory test starts. When
> it is completed, the system resets. Sometimes the value of obs is 0x50200000.
> Sometimes it is not obs=.. but a5=0x00000000. I have pulled out the SCSI card
> but that has no effect.
> _______________________________________________
> rescue list - http://www.sunhelp.org/mailman/listinfo/rescue

More information about the rescue mailing list