[rescue] Sun 3/110 Netbooting...

Peter Stokes peter at ashlyn.co.uk
Fri May 16 01:51:41 CDT 2014

Hi Earl

Sorry, cannot directly help with the netboot, but as you say you are close
from the sound of it, but do not have any of the Sun 3 info here, except to
say I thought the Sunos 4.X was very similar to Sunos 3.X in terms of booting,
given that 4.X was essentially for Sparc and 3.X was for the 3 series 68XXXX,
so maybe look at that approach?

>From memory I seem to remember a two stage boot, but sadly way too long ago
since I played with Sun 3's (back in 90s).

On the disk boot, I think you need to get the netboot working as the UFS FS
and label for the disk are likely to be needing an old version, again from
memory and later UFS and labels may not be readable sensibly by the Sun 3. I
do remember the format prog was different on Sunos 4 to Sunos 5, such that 5
could read 4 labels, but not sure if ok the other way round.

One quick question, are the tape images available as a download?

You could of course try to recreate the tapes on a different tape drive other
than the QIC drive.

Peter Stokes
Ashlyn Computer Services
Tel: 01636 627990
Mbl: 07977 532320

On 16 May 2014, at 06:56, Earl Baugh <earl at baugh.org> wrote:

> Howdy again,
> Well, I've made  "some" progress but now have to rely on more of the
> collective knowledge of the rescue folks.
> Here are the steps I've been attempting and results...
> Step 1 : Get Sun 3/110 to obtain IP address via RARPD on Mac.
> I have successfully got the Sun 3/110 obtaining an IP address from the Mac
> (directly!) using tftpd and rarpd
> Seems to work consistently.
> Step 2 : Get Sun 3/110 to download file via TFTPD on Mac
> I have successfully got the Sun 3/110 to download a file from the Mac where
> it has gotten it's IP address from.
> I can tell it's downloading the file I expect by the number of bytes and
> when I change the file I get different download totals.
> Step 3: Figure out what the /tftpd directory configuration should be for
> Sun OS 3.5 netbooting
> This one I haven't had any real success in looking up.   I believe I have
> some good images of the tapes for Sun OS 3.5,
> they unpack ok.   However translating the tapes into what should be there
> to boot the machine, that's a different problem.
> In Step 2, I've tried downloading "boot" which does download and then
> generates "Exception 0x10 at 00004014".
> I tried downloading "vmunix" which does download, but then hangs the
> monitor (it goes to black, and doesn't seem to come
> back...maybe I've not waited long enough, but I didn't recall the screen
> hanging long, long ago when I did this.
> (as a side note, on Step 1, when it succeeds, it's lightning fast, and gets
> into Step 2 pretty much immediately.. about as fast
> as it can print the text... when it's not set up correctly, it drags and
> drags...)
> So, the question is does anyone have a directory listing of a Sun OS 3.5
> client boot directory structure, including the /tftpboot
> area?   It feels like I'm close...
> Thanks!
> Earl
> _______________________________________________
> rescue list - http://www.sunhelp.org/mailman/listinfo/rescue

More information about the rescue mailing list