[rescue] Help with SunFire V240 Server

Meelis Roos mroos at linux.ee
Fri Apr 5 01:26:54 CDT 2013

> And, of course, since this server does not have a DVD drive on-board, how
> should I go about installing an OS? Is a USB optical drive an option? USB
> flash drive? I don't have a boot server available and would prefer to not
> set one up if at all possible.

I have one similar machine (albeit the disks are SCA SCSI, probably 
yours are too).

It can not boot from USB stick or USB DVD-ROM.

IDE CD or ID DVD can be added but CD is not much workh for Solaris (most 
newer releases are DVD images). I tried with 5 DVD drives and found only 
one that worked - a DVD-RW. probe-ide did not find the others. A friend 
with V240 had similar problem that only DVD-RW was recoginsed, not plain 
DVD. Strange but noteworthy.

You can of course boot from the network - for Solaris, FreeBSD, OpenBSD 
you need rarp, tftp, nfs, bootparam. For Linux and NetBSD, rarp+tftp is 
sufficient because initial ramdisk is glued to tftp boot image.

External SCSI port with a chain of cabling to get to old CD drives would 
probably work but DVD drive is more useful with Solaris and SCSI DVD-s 
are rare (but not nonexistant).

You might or might not want to upgrade to newest PROM. I upgraded mine 
and the 3rd party dimms that were added to Sun ones were now 
disqualified because of too high CAS latency. With original DIMMs there 
is of course no problem.

I had password on my V240-s ALOM but I could get to prom promt. so the 
solution was to install solaris and reset the password from Solaris with 
scadm (and also upgrading alom main and boot firmware while at it).

On old-enough ALOM it was possible to reset the settings (including 
password) from ALOM interrupted boot on serial console. On newer 
releases this is not possible any more and needs to be done from Solaris 
(that's why I have a HDD with pre-installed Solaris archived).

SSH to ALOM works but is somewhat strange - whatever username I supply, 
it connects without asking for password with ssh protocol and then asks 
for username and password inside the established SSH pipe.

Do connect to ALOM too and see if you have some alerts - mine has one 
fan worn out and it is too slow.

I run Debian on my V210 and V240, to test new kernels. Generally it 
works, distro kernels are OK but if I specifically select some different 
set of kernel consfiguration options, it can hang sometimes. One such 
configuration option is transaparent hugepages but there is at leaste 
one more. So compiling my own kernels is fun for development but if ypu 
want to make use of it with some Linux-specific stuff, stick with distro 

Meelis Roos (mroos at linux.ee)

More information about the rescue mailing list