[rescue] Solaris 10 x86 repair

Phil Stracchino alaric at metrocast.net
Sun Sep 5 20:28:12 CDT 2010

On 09/05/10 21:12, Patrick Giagnocavo wrote:
> You want to check /boot/grub/menu.lst and read the man page for bootadm.

Yeah, done all of those.  I managed to get it manually booted failsafe
using grub on the Solaris 10/09 DVD once, but was unable to mount my ZFS
pools from failsafe because the on-disk ZFS has been upgraded and is
newer than the failsafe miniroot.  I've tried several times to reinstall
grub from the install DVD, but it doesn't yield a bootable system; I
don't seem to be able to update the boot archive from the DVD's miniroot
and get a bootable boot archive, and can't do it from the existing
install's miniroot because it can't mount the ZFS pools.  Everything
I've thought of to try, I run into one wall or another.  Part of the
problem is that I don't know exactly *what* went wrong, and can't find
any clues.  The last event in babylon4's logs is successful completion
of its incremental backup at 04:06:20; then no clues anywhere until at
05:08:41, NUT upsmon polls from babylon5 start failing.  All the
hardware appears to be working fine, and both zpools are clean.

At this point, I'm sending snapshots of all the ZFS filesystems from the
root pool over to the main array pool, and as soon as I have them all
backed up, I'm going to do a clean reinstall of u8 10/09, the newest I
have.  And then after I get it back up, I get to investigate why my V210
is *also* not responding.  (Did they have some kind of snit and beat
each other senseless or something...?)

  Phil Stracchino, CDK#2     DoD#299792458     ICBM: 43.5607, -71.355
  alaric at caerllewys.net   alaric at metrocast.net   phil at co.ordinate.org
         Renaissance Man, Unix ronin, Perl hacker, Free Stater
                 It's not the years, it's the mileage.

More information about the rescue mailing list