[rescue] SPARCEngine AXi NVRAM problem

John Ruschmeyer jruschme at gmail.com
Sat Nov 20 07:28:16 CST 2010

As I may have mentioned, I am trying to set up a SPARCEngine AXi board which
has been sitting in my project pile for some time.

When I received this board from another list member, I was told that it had
a NVRAM problem which, I assumed, was a dead battery. After playing with it
for a while, I'm not sure that is the case, but don't really know what the
problem is.

When I first started working with it, the banner showed an invalid, but
non-zero Ethernet address and HOSTID. Following the venerable NVRAM FAQ, I
reset the IDPROM values, including the checksum. The NVRAM is maintaing this
information across power downs and I've even installed the board in a case
with CD and SCSI drive and have it running Solaris Express 11 (with the
clock maintaining time even with the power removed). Needless to say, I
think the battery is okay.

Despite all this, however, whenever I power the system on, I get the

Incorrect configuration checksum;
Setting NVRAM parameters to default values.
Setting diag-switch? NVRAM parameter to true
Reset Control: BXIR:0 BPOR:0 SXIR:0 SPOR:0 POR:1

I've also tried powering on with Stop-N and been told that the NVRAM is
being set to defaults, but get the same error on next reset.

Somewhat disturbingly, when I try to run "set-defaults" from the prompt, I
get the "Fast Data Access MMU Miss".

Help! Has anybody seen a problem like this before? Any suggestions as to
what to try or how to fix it?


More information about the rescue mailing list