[rescue] A tale of two Sun A5000's

Mr Ian Primus ian_primus at yahoo.com
Tue Mar 30 22:28:50 CDT 2010

Update: Found the firmware. It lives on a PLCC chip on the interconnect board. I tried swapping the chips between the arrays, this did NOT move the problem, although it did move the firmware and configs (name, etc). The problem stayed with the faulty array.

As a stress-test of the good array, I fitted a replacement power supply, replaced the noisy fans and loaded it up with disks. I set the whole thing up as a big RAID-5 array, and I'm writing data to it. So far, no errors whatsoever. My disks and I/O boards are obviously functional.

The faulty array.. I'm not sure. I guess it's gotta be something wrong with the interconnect board or one of the backplanes. My bet would be on the interconnect board, since I've had I/O errors on disks in both the front and rear slots.

Only other thing I can think of is an electrically noisy power supply. I have not tried swapping power supplies between the arrays.

Anyone got a junked A5000 carcass with an interconnect board/backplanes still in it?


More information about the rescue mailing list