[rescue] Trouble installing HP-UX 11i on a J6700

Micah R Ledbetter vlack at vlack.com
Wed Mar 11 03:31:07 CDT 2009

Hello all.

I know practically nothing about HP-UX, so I've included a great deal  
of maybe-unnecessary detail. Sorry about that. My hope is that I've  
included enough to make sense, and that someone else with a similar  
problem might find a solution (the hope being, of course, that there  
is one to be had ;p).

I bought an HP J6700 a while back, and got HP-UX 11i running on it  
without much difficulty. I ran into a networking issue which I  
definitely knew could be solved without a reinstall, but after  
screwing around with it for a week or so, I got annoyed and nuked it.  
Booted from the install discs and start over.

Only this time, I get an error. I go through the install setup phase,  
and get to the part where it actually installs the packages. It always  
bombs out before having me switch from the first install disc to any  
of the three others, but on different packages each time.

The most recent failure, it errored with this exact text:

         * Installing fileset "ProgSupport.C-INC,r=B.11.11 (70 of 746)
ERROR:    RPC exception: "Communications failure (dce / rpc)" 03/11/09
           01:07:12 EST
ERROR:    Could not perform the requested operation for "loopback:/",
           possibly due to a network communications failure or the agent
           timing out.  Check that the host is still accessible from the
           network, and the agent_timeout_minutes option is not set too
ERROR:    Software load had one or more erros.
WARNING:  Will continue and verify that key filesets have been loaded
ERROR:    Software "JFS.VXFS-BASE-RUN" was not found on host
WARNING:  Because some key filesets were found to be missing, you must  
now retry
           the software load process to load them.

=======   03/11/09 01:07:12 EST  The operating system software has not  
           successfully loaded. The swinstall(1M) application was not  
           or failed to load some key files. (exit status was = 1).

           1: Change the swinstall server and/or depot information
           2: Retry software load process (non-interactive mode).
           3: Retry software load process (interactive mode).
           4: Run a shell.

Selecting option 2 results in the error being displayed again.

Selecting option 3 prevents me with a little text-mode gui window,  
entitled "Select Target Path (loopback)", and having the contents  
"Target Host: loopback" and "Root Path...: /"; I can tab to the "Root  
Path..." item and change it to something else. My options are "/" and  
"/export/shared_roots/OS_700"; if I leave it at the default ("/"), it  
replies with a box which says ...

	"loopback:/":  This target or source is already in use either within
	this same session or by another session.  A read or write lock was

... and then it redisplays the previous window where I can select the  
root path.

I can select the other option, "/exports/shared_roots/OS_700" and then  
go to Actions -> Install in the resulting window, but I get this error:

         "The target "loopback:/exports/shared_roots/OS_700" failed  
Disk Space
         Analysis, so the task cannot be executed.  For more  
information on
         this failure, press the "Disk Space..." button

I don't know what /exports/shared_roots/OS_700 is, at all. I wonder if  
it might be the mount point for the cdrom, or something.

On this particular install attempt, I started with the Veritas Volume  
Manager and the VxFS filesystem, used guided install mode, and except  
for changing the root FS type, kept all of the other defaults.

The package that fails isn't always this one - at one point, I thought  
it was related to Veritas VxFS because the package for that failed -  
but it's always the error with "loopback:/"

I've tried it before with advanced mode and going to specifically  
remove packages that I 1) knew what they were and 2) didn't think I'd  
need them, and I've tried the "no user interaction, just install it"  
option that presents itself at the very beginning of the install  
process. They all end with a similar error.

I just now added another disk and increased the disk space for every  
partition, when trying again with an advanced mode install. The error  
message was similar.

The system has two network interfaces - an onboard 10/100 interface  
and a PCI gigabit interface. Both were present at the time of the  
initial, working HP-UX install. I've recently tried it with a network  
connected to one slot, and then the other; the error message is similar.

OK, that's all the information I can think of. I'm pulling my hair  
out, here, and I'd be really grateful for any pointers. Thanks.

  - Micah

More information about the rescue mailing list