[rescue] Sun v240 serial console

Pete leaknoil at comcast.net
Mon Feb 23 01:49:40 CST 2009

OK I'm stuck. I have a Sun V240 here that talks to me but, I cant talk to.

I have tried a few different cables etc on the serial mgt port and 
nothing. Everything is set to 9600 8n1. No flow control. This same setup 
works with every other rj45 LOM based sun I have. Just not this 240.

It displays all the normal boot up or diagnostic messages but, when it 
gets to any place for input I can't enter anything. Be it 'ok' or 'enter 
#.'  Sending a break does nothing as well.

I tried hooking up a Sun usb keyboard and when I set the box into diag 
mode it is reported as keyboard found but, nothing I type on it works. 
On other Sun's I've tried this on its worked when there was serial cable 

I have no idea about any previous settings of this machine. I cant do a 
printenv or such to see them so, no idea what the thing is set to. The 
same exact cable setup works fine with a b1600, v120, X1, t1/ac200, and 
everything else I've tried so far. It feels like a config issue.

I tried popping out the battery and doing the clear cmos jumper but, no 
change. These things have a SCC smart card that holds some config info 
so, it may be in there anyway.  I have no other 240 to swap cards with 
and the cards from other Sun's just give me SCC in not valid messages.

Any ideas ?

More information about the rescue mailing list