[rescue] net install redux

Mike F lists at ibrew.net
Tue Mar 11 11:32:45 CDT 2008

On Mar 10, 2008, at 5:21 PM, awouk at nilenet.com (Arthur Wouk) wrote:

> i screwed up the install of sol 10 on my ultra-2, whose cdrom is dead.
> so i tried to re-install using net install, as per Mike F's  
> instructions
> as of a year ago, posted on the rescue list. [i am running the  
> install from  a blade 100 called blade.]
> I started using the following when update4 of sol 10 came out,  
> avoiding burning cds.
> it worked just fine at that time.
>> Date: Fri, 30 Jun 2006 15:54:32 -0400
>> From: Mike F <lists at ibrew.net>
>> Subject: Re: [rescue] Pointers or how-to create an install server?
>> For me, the easiest way is to first download the Solaris 10 DVD image
>> and cat the parts together to reassemble the DVD iso.
>> Add the iso image as a loopback device:
>> 'lofiadm -a /path/to/solaris.iso'
>> Mount the lofi device as a filesystem:
>> mount -F hsfs /dev/lofi/1 /mnt
>> cd /mnt/Solaris_10/Tools
>> ./add_install_client -i 192.168.x.x -e aa:bb:cc:dd;ee:ff machine_name
>> machine_platform
>> where:
>> -i specifies the client's ip address, -e specifies the client's MAC
>> address, machine_name is the client's short hostname, and
>> machine_platform is sun4u, etc.
>> add_install_client will populate the necessary files in /etc and  
>> turn on
>> all the appropriate services (through SMF.)
>> repeat the add_install_client script for additional clients and  
>> 'svcadm
>> -v restart rarp nfs/server bootparams' to make sure everything is  
>> updated.
> ==================================================================
> here is what i get:
> blade> add_install_client -i  -e 8:0:20:79:84:ad ul2  
> sun4u
> blade> making /tftpboot
> svcprop: Pattern 'network/tftp/udp6:default/:properties/restarter/ 
> state' doesn't match any entities
> enabling network/tftp/udp6 service
> svcadm: Pattern 'network/tftp/udp6' doesn't match any instances
> updating /etc/bootparams
> copying boot file to /tftpboot/inetboot.SUN4U.Solaris_10-1
> whenever i try to install on any machine,  'boot net -i install'  
> fails with
> a failure to connect.
> any clue as to what is wrong?

 From the errors above it looks like the tftp server is not getting  
enabled, or at least not for ipv6. I'm not in front of a Solaris  
machine now, but I believe "svcadm -v enable tftp" should enable it,  
or if it's already enabled show its status.

However, one thing I noticed when doing net installs was that  
sometimes the client would simply never "find" the server. In this  
case, start pinging the client from the server as you boot net. This  
way, the server's address is guaranteed to be in the client's arp table.

Finally, if memory serves, all that is needed on the client is a "boot  
net" with no further arguments, since what it's booting is install  

- Mike

More information about the rescue mailing list