[rescue] Sun Blade 150

Curious George jorge234q at yahoo.com
Thu Jul 10 14:18:41 CDT 2008


--- On Tue, 7/8/08, Halford Johnson <halfordjohnson at gmail.com> wrote:

> On Tue, Jul 8, 2008 at 10:12 PM, Lionel Peterson
> <lionel4287 at verizon.net>
> wrote:
> HAve you tried stop-N? That would reset the NVRAM to
> default values, that has helped me revive a couple systems...
> >
> > To review, you would power up the system, then
> immediately hold down "stop"
> > and "n" on a Sun keyboard, holding them down
> until the keyboard lights
> > cycle
> > twice... (the first is power up, the second is the
> reset) then simply
> > release
> > the keys and the systme *might* boot up.
> >
> > You would do this with a Sun keyboard and VGA monitor
> attached, I'm sure
> > you
> > can use serial console to do this, but I don't
> know the equivalent key
> > presses...
> I received this machine in unknown condition.
> Here is what I've tried:
> I've tried using a serial cable 8n1 9600 with hardware
> flow control and
> again with no flow control --- nothing.

With *nothing* plugged into the keyboard, right?
(note this still relies on NVRAM settings)

> I've tried hooking up a VGA monitor and generic USB
> keyboard, no display.

I'm not sure a generic USB keyboard will work.  I used
an SGI USB keyboard on my Tatung SB1000 without problems
but I am not sure just how closely the Tatung and Sun
designs are (were).

> I've tried multiple single sticks of PC133 ECC RAM in
> multiple slots, no display.
> Seems pretty dead.  I am not sure what else to try.  I
> would like to repair
> this machine, but I first must determine the problem.

Of course!  :>  That's the $64000 question!

> I thought perhaps the motherboard might be dead, but I
> noted that when I
> remove all the RAM, it gives the no RAM system beeping
> error.  When I insert
> RAM, there is no noise, just fans running. (All LEDs turn
> on successfully)

I would *think* the CPU has to be running in order to
- query the RAM (i.e., is it there and is it the right flavor)
- alert you to the problem (i.e., beep)

> This leads me to hypothesize that perhaps it is the CPU
> that is bad?

I would disagree, there!  I.e., the CPU is working well
enough to execute its POST out of ROM.  The fact that it
doesn't behave when there is RAM present could mean
bad/wrong RAM, bad memory controller, etc.  But, the
CPU doesn't seem to be *toast* (i.e., if you removed the
CPU chip itself, you would find the symptoms different)

> Any thoughts?

Different RAM.  I am not sure if the SB150 queries the
RAM devices to determine *exactly* what flavor they are
(there is usually a small, 8 pin SOIC on one corner of the
DIMM that has "configuration" information stored in it
that lets a processor determine the speed, size, etc.
of each individual stick of memory in the machine).

Also not sure just how smart the POST is in this regard.
I.e., if it sees something it doesn't like, can it *tell*
you that?  Or, does it just hang??


If you decide to EOL the machine, I'd be interested in it's
*skin* (assuming it is in good cosmetic shape) for my SB150.

Good luck!

More information about the rescue mailing list