[rescue] Solaris 10 / DDS-3 drive issues (ongoing)

Bill Bradford mrbill at mrbill.net
Tue May 1 10:29:35 CDT 2007

I'm having a heck of a time getting an IBM-firmwared 12/24gig DDS-3
tape drive to work under Solaris 10 (update 2).  

System is a 333Mhz Ultra 10 with 1G RAM.

>From a probe-scsi-all:

/pci at 1f,0/pci at 1/scsi at 1
Target 0
  Unit 0   Disk     SEAGATE ST336704LC      0004
Target 4
  Unit 0   Removable Tape     ARCHIVE IBM-STD224000N!D7430
Target 6
  Unit 0   Removable Read Only device    TOSHIBA DVD-ROM SD-M14011009

The initital probe, before any st.conf changes:

root at bradford:/kernel/drv> mt -f /dev/rmt/0mbn status
Unconfigured Drive: Vendor 'ARCHIVE ' Product 'IBM-STD224000N!' tape drive:
   sense key(0x6)= Unit Attention   residual= 0   retries= 0
   file no= 0   block no= 0

The manual (http://www.mrbill.net/tapedrive.pdf) said to use these 
settings in st.conf:

SEAGATE_DAT = 1,0x2c,0,0xd639,4,0x00,0x8C,0x8C,0x8C,3;

Tried that (with the product ID changed to match what the drive puts out), 
It appears to see the drive just fine during the SCSI device probe:

/pci at 1f,0/pci at 1/scsi at 1/st at 4,0 (st4):
        <Seagate Scorpion 24 DAT>
st4 at glm0: target 4 lun 0
st4 is /pci at 1f,0/pci at 1/scsi at 1/st at 4,0

and then doesn't know when I've inserted a tape.  "No tape inserted or
drive offline".

Doing a "mt <dev> config" on the drive gives me the following:
"ARCHIVE IBM-STD224000N!", "Seagate Scorpion 24 DAT",

Tried that, same result (it doesn't know when a tape is in).

Finally, I dug up these settings from an old shipped-with-solaris st.conf
file circa 2003 (with product IDs changed to match the drive output):

"ARCHIVE IBM-STD224000N!", "Seagate DAT", "ARCH_04106";
ARCH_04106 = 1, 0x2C, 0, 0x09639, 4, 0x00, 0x8C, 0x8C, 0x8C, 3;

Same result:

root at bradford:/> mt -f /dev/rmt/0n status
/dev/rmt/0n: no tape loaded or drive offline

Any suggestions?  When I don't configure the drive in st.conf at all, 
*then* it knows when a tape is inserted.. but once I do "proper" setup
for the drive (in order to be able to read the tape), it loses its mind.


Bill Bradford 
Houston, Texas

More information about the rescue mailing list