[rescue] Solaris 9 NFS client with Linux server

Steve Sandau ssandau at gwi.net
Tue Aug 21 17:29:49 CDT 2007

> [...]
>> Now I just unmounted it, tried some other options (version 2 is what makes
>> it work) and seem to have introduced some slowness just by remounting it.
>> When it is slow, or when it pauses, ethereal shows a packet labeled as
>> "fragmented IP protocol", "RPC retransmission", "RPC duplicate" packets
>> and a single ICMP packet labeled "Time to live exceeded (fragment
>> reassembly time exceeded)".
>> Maybe someone else can make some sense of that, but I'd think there were 
>> network problems or the NIC in the server was a problem if scp from this 
>> box and NFS from other boxes didn't work fine.
> It sure smells like a network configuration problem to me. This kind of
> failure is usually due to some incompetent berk configuring a packet filter
> and blocking unusual but important packets and options because they don't
> know what they do and so assume they're bad.
Well, it appears that this actually has something to do with the 9 
Recommended patch cluster. I took another Ultra with a new install of 
Sol 9, and it worked fine as an NFS client. After installing the patch 
cluster, it no longer works as an NFS client to the Linux box.

It would appear that the fault is in the Linux box, probably, unless a 
recent patch cluster contains an NFS bug.  I was going to back out the 
NFS patches from my Ultra 2, but even though the install script for the 
patch cluster swears that patchadd is run with the -save option, the 
patches cannot be backed out. I figure it is not an NFS patch now, 
anyway, since the application of the three NFS patches in the cluster to 
a fresh Sol 9 install does not break the NFS client to Linux server.

Any other thoughts before I find some workaround like not patching my 


More information about the rescue mailing list