[rescue] Solaris 9 NFS client with Linux server

Steve Sandau ssandau at gwi.net
Wed Aug 8 06:45:59 CDT 2007

>> The kernel NFS server ("aptitude install nfs-kernel-server") just works for
>> me on Debian, with Linux and MacOS clients, over both Fast Ethernet and
>> 802.11g.
> Yep, likewise. I'm using it with a mix of NetBSD, FreeBSD, Linux and OS X
> clients without problem (OpenSolaris too at a stage). When I still had a
> Solaris 9 client system, I did have lots of funnies though. Some were
> related to GNOME locking (which can be solved by forcing GConf to use local
> locks), but others were just inexplicable - directories that had been
> deleted were still visible on the client, etc. I never got to the bottom of
> them...

Well, after considerable experimentation (i.e. a ratio of trial and 
error close to 1:1), it seems that I apparently finally got this to work 
using "mount -o proto=tcp -o vers=2 mrsnorton:/raid /import" to mount 
the share. It appears to be slightly more responsive using "proto=udp" 

I thought I had tried forcing this to version 2 before, but that did it 
unless something else changed between last night and this morning.

Now I just unmounted it, tried some other options (version 2 is what 
makes it work) and seem to have introduced some slowness just by 
remounting it. When it is slow, or when it pauses, ethereal shows a 
packet labeled as "fragmented IP protocol", "RPC retransmission", "RPC 
duplicate" packets and a single ICMP packet labeled "Time to live 
exceeded (fragment reassembly time exceeded)".

Maybe someone else can make some sense of that, but I'd think there were 
network problems or the NIC in the server was a problem if scp from this 
box and NFS from other boxes didn't work fine.

Still somewhat of a mystery...


More information about the rescue mailing list