[rescue] Solaris 9 NFS client with Linux server

Steve Sandau ssandau at gwi.net
Tue Aug 7 18:58:28 CDT 2007

Geoffrey S. Mendelson wrote:
> On Tue, Aug 07, 2007 at 07:32:14AM -0400, Steve Sandau wrote:
>> I have tried different versions of the mount command including such 
>> options as rsize=1024 wsize=1024 proto=tcp vers=3 without changing the 
>> behavior at all. There is no firewall on either box, and they are on the 
>> same network with nothing but a 10m hub in between.
> Try UDP instead of TCP. NFS over TCP is not supported well in older Linux systems
> (if at all), and in a LAN adds a lot of extra uneccessary overhead.

I tried UDP and have the same problem unfortunately. I am not sure what 
the default is, UDP or TCP.

I have another clue, though. This server works fine with Linux clients 
and Sol 10 clients, but is broken with Sol 9 clients, SPARC and x86. Is 
there possibly a daemon that I have neglected to start that could cause 

I don't think it is DNS-related at all; mounting with the IP address 
instead of the name causes the same thing.

Running ethereal shows a problem 'ls' generating a "READDIRPLUS" request 
that a working response does not have. After that I get fragmented UDP 
packets, duplicates and retransmissions. But a sniff of an sftp session 
shows no such errors.



More information about the rescue mailing list