[rescue] Solaris 9 NFS client with Linux server

Steve Sandau ssandau at gwi.net
Tue Aug 7 06:32:14 CDT 2007

I posted this to Sunhelp a few days ago without much response and with 
no solution still. Maybe someone here has a suggestion or two.

I have tried to figure this one out on my own with copious Googling, but 
to no avail. Maybe there is someone here who has some suggestions. I'll 
try to detail what I have tried so far.

I have a Slackware Linux NFS server (2.4.9 kernel on a dual P166 CPU IBM 
PCServer 320!) that works fine with Solaris 10 x86 and Linux clients. I 
use it on a daily basis from my Slackware 10 workstation.

Partly because of discussions of speed on this list, I just went "back" 
to Solaris 9 on my Ultra2. I am generally pleased with the outcome, but 
I am unable to get my home directory NFS mount to work properly.

I can mount the share, and run 'ls' on some directories, but not all. 
The directories that produce listings appear to be the ones that have 
short listings. For most directories, 'ls' on the Solaris client hangs 
and eventually gives me a message to the effect that the NFS server is 
not responding but that the client is still trying.

I have tried different versions of the mount command including such 
options as rsize=1024 wsize=1024 proto=tcp vers=3 without changing the 
behavior at all. There is no firewall on either box, and they are on the 
same network with nothing but a 10m hub in between.

Anyone have any ideas? Let me know if I have left anything out.



More information about the rescue mailing list