[rescue] Sun Kit Needed for EE Student Here

Don Y dgy at DakotaCom.Net
Fri May 5 05:35:46 CDT 2006

Charles Shannon Hendrix wrote:
> Thu, 04 May 2006 @ 19:03 -0400, der Mouse said:
>>> and your problem has nothing to do with PCs in general.
>> In theory, no.  In practice, yes.  In theory, there is no need for a
>> BIOS to misbehave like that.  But if some large fraction of them do -
>> and I consider that vendor's comments as fairly strong evidence that
>> they do - then it's a case of "99% of them give the rest a bad name".
> PC BIOS sucks, but the problem you are having hasn't been on any system I've
> bought in the last 5 years.

It seems to creep in every time there is a "quantum" size increase
in disk capacities.  As if the folks writing this stuff can't
learn from their past mistakes and do wide enough math, etc.

> It really sounds like you got a buggy BIOS. Have you tried to find an updated
> BIOS and flash that?
> It could even be a bug with IDE that the BIOS just can't handle, triggered by
> a different drive.
>>> I have had a couple of Suns that had the same problem.
>> Interesting.  Which models and ROM revs?  
> Well, I have to admit now that I've thought about it more, some of it was
> about trouble with SunOS and Solaris, not the ROMs, and ESDI and ESDI bridged
> drives. I used to hate Sun's disk setup. Actually I still do, but I just
> rarely have to use it now that NetBSD is my primary OS.

Though NBSD's "installboot" is still something that I have
to think twice about *how* I want to do it (when building a second
bootable disk).  Something counterintuitive there...

> However, there were also issues with ROM and SCSI, and the units I remember
> most were Sun SPARC towers (the VMEbus systems), Sun SS1 and SS2, and my
> current Sun SS5.

And, problems if you abort the boot and try to do things like
probe-scsi... (this is particularly annoying since, if the boot
isn't working -- hence the reason to abort it -- you are
deprived of that one very useful tool to explore why it
isn't booting as expected!)

> The symptoms:
> The Sun would see the drive, but not the right model or capacity.
> The Sun would see the drive, but was unable to boot from it and/or I could not
> install the OS.
> In all of these cases, a convienient Mac or PC was able to see and use the
> drives just fine (except for ESDI, which I never used outside of Sun systems).
> The SS5 generally just works, but I did have a drive once that it never saw as
> the correct drive, and I had trouble installing an OS on it.  I gave up
> trying to figure it out and got a pair of IBM 9GB drives which work
> fine.

My SS5 is giving me an error (F-code?) just before/after the
power up banner.  I'll have to hook up a monitor and see what
it is saying...  (it seems to *run* OK...)

> The largest drive I have tried on the SS5 is an 18GB Fujitsu, and it
> also works fine.

Ditto.  I use 18G drives in all of my SCA Suns without problems.
Never tried anything larger than that (nor do I *want* to  :< )

BTW, I have some notes I wrote up describing how to hack a
half-height drive into an SS5/20 if anyone is interested...

More information about the rescue mailing list