[rescue] Fixing the NVRAM battery in the SS5

Sridhar Ayengar ploopster at gmail.com
Fri Jan 6 14:07:50 CST 2006

Bryan Gurney wrote:
> I might try NetBSD, since Sarge doesn't play nice with the serial console  
> (and for a machine that is destined to run headless, that just won't do).   
> Sarge seems to run a bit heavy, and defaults to installing things like  
> exim4, etc. that I just don't need.  Sure, I could remove them, but then  
> there's all the "Unimplemented Sparc system call X" messages on the  
> console, and a few other things that are broken.  Time to experience  
> another OS; I've gone through Winders, Mac System 7.5 through OS X 10.4,  
> RedHat 6.2, Fedora, Debian Woody SPARC, Solaris 9 and 10.  I've tried and  
> tried to set up OpenBSD on the SS5 but it always wedges at some point.

That's odd.  Is it a different place every time or the same place 

> Back to the original reason for the post, I fired it up today, and saw  
> this when Debian Sarge started up:
> System Clock set. Local time: Mon Nov 21 17:50:51 EST 2005
> I think that might have been the last time I powered on the machine, and I  
> think I set the date as well.  My stopgap is to use ntpdate for now, but  
> still, this thing may boot up with a MAC address of FF:FF:FF:FF:FF:FF or  
> something, and refuse to continue.  (Or was that the SGI NVRAM failure  
> mode?  I can't quite remember).

One good fix for this might be to start ntpd from an install script. 
Even better would be to have an init script use ntpdate to sync the 
clock and *then* start ntpd.

Peace...  Sridhar

More information about the rescue mailing list