[rescue] Motorola Powerstack help needed

Sridhar Ayengar ploopster at gmail.com
Sun Aug 20 11:26:51 CDT 2006

Meelis Roos wrote:
> Hi,
> I have a Motorola Powerstack II Pro4000 (PReP IBM clone) as my gateway 
> here (PPC 604e 300 MHz, IBM chipset, PCI CL5446 VGA, onboard Sym82c825 
> SCSI, 192M RAM, Asante PCI NIC with DC-21140, Adaptec 2940 additional 
> PCI SCSI). It's running Linux to keep testing that newer versions of 
> Linux work fine on it (have caught several problem in the past).
> But the machine has been behaving strange lately, with software that 
> worked fine before.
> All was well until I found that I can not boot the latest selfcompiled 
> kernel from disk. Linux kernel has a small loader at the beginning that 
> asks for boot command line. I have set a default command line and now 
> the command line was mangled and overwrittent with lots of copies of 
> previously outputed string fragment " loaded at 0".
> OK, seems like a glitch with the kernel. But things got even worse - I 
> could not successfully boot previously working kernel images either. The 
> same effect happens to them, with varying level. The kernel either fails 
> to boot at all or boots and gets garbage as the boot command line and 
> never finds the root to mount.
> By trial and error I found an older kernel image that got the command 
> line corrupted but root= part happened to be untouched so I could boot 
> up again.
> I tried the following thing and none helped, so now I'm out of ideas and 
> hope somebody here has some ideas.
> Tried set-defaults in OF prompt, removing secondary NIC and secondary 
> scsi adapter, tried with only one set of RAM sticks (original 2x32M and 
> Compaq 2x64M), booted from disk and from network. Nothing helped.
> Any ideas?

Have you tried booting a fresh copy of the newer kernel from read-only 

Peace...  Sridhar

More information about the rescue mailing list