[rescue] ultra 2 drive not recognised

Jonathan C. Patschke jp at celestrion.net
Thu May 12 11:28:08 CDT 2005

On Thu, 12 May 2005, Francois Dion wrote:

>> I am going to sales pitch for devfsadm.
> What is the difference between that and using cfgadm -c configure
> _hardware_?

devfsadm makes device nodes and updates path_to_inst (which is used to
connect kernel module instances to the device tree).  cfgadm deals with
dynamic configuration, which is at a lower level of abstraction.

> I actually tried that, as usually this always works for me. I've added
> and removed many disks from V240, V440 etc using that. On the U2 it
> didn't work, cfgadm -al didn't show the extra drive, but I was more
> under the impression it was because of the disk not having a label
> that was recognised by Solaris.

Solaris will see an unlabeled disk as an unlabeled disk.  It will still
get an sd instance attached to it.  If it didn't, format wouldn't be
able to label unlabeled disks.

> That's why I didn't have to reboot, just using disks and drvconfig. It
> basically does the same. I'm not sure they are link tough, I'm looking
> at the files and they seem large binaries.

They're hard links:

   [jp at hythloth:/usr/sbin]$ sum disks tapes ports devlinks drvconfig \
   12812    71 disks
   12812    71 tapes
   12812    71 ports
   12812    71 devlinks
   12812    71 drvconfig
   12812    71 audlinks

> Thanks for the details. I'm still not clear why devfsadm or disks
> (assuming they are the same) worked, but cfgadm -c configure didn't. A
> wild guess is that if I had done drvconfig after that it probably
> would have shown up, versus I suspect cfgadm does it automagically if
> the drive is already prepped for Solaris.

Nope.  Solaris attaches drivers according to path_to_inst, rather than
the OpenBoot device tree (a major difference between Solaris and, say,
Linux), and path_to_inst only gets updated by devfsadm.  The reasoning
behind this is that probing something like a fully-configured E6500 is
slow and potentially error-prone.  Also, it means that your devices
don't "walk around" because some new driver changed the probe order[0].

[0] The infamous "Okay, who's /dev/sda -now-?" problem on pre-devfs
     Linux and some BSDs.
Jonathan Patschke  ) "It's alright for someone to sleep past noon every
Elgin, TX         (   once in a while.  That's what it means to be a
USA                )  free human being."       --Roger Smith, The Big O

More information about the rescue mailing list