[rescue] ultra 2 drive not recognised

Francois Dion francois.dion at gmail.com
Thu May 12 08:30:31 CDT 2005

On 5/11/05, velociraptor <velociraptor at gmail.com> wrote:
> On 5/11/05, Francois Dion <francois.dion at gmail.com> wrote:
> > On 5/11/05, bitrot <bitrot at apshai.com> wrote:
> > > disks;drvconfig
> >
> > Allright! That worked, thanks.
> >
> I am going to sales pitch for devfsadm.

What is the difference between that and using cfgadm -c configure _hardware_?

I actually tried that, as usually this always works for me. I've added
and removed many disks from V240, V440 etc using that. On the U2 it
didn't work, cfgadm -al didn't show the extra drive, but I was more
under the impression it was because of the disk not having a label
that was recognised by Solaris.

Apparently, that was not the whole story, and I have a hard time
understanding the mechanism behind the scene. Hopefully, Open Solaris
is right around the corner and this will become pretty obvious at that

>      devfsadm(1M) maintains the /dev and /devices namespaces.  It
>      replaces  the  previous  suite of devfs administration tools
>      including drvconfig(1M),  disks(1M),  tapes(1M),  ports(1M),
>      audlinks(1M), and devlinks(1M).
>     (Those progs are just links to devfsadm now.)

That's why I didn't have to reboot, just using disks and drvconfig. It
basically does the same. I'm not sure they are link tough, I'm looking
at the files and they seem large binaries.

> devfsadm has the advantages of:
>   *can be used to clean up "dangling" links for non-existant
>    hardware if you take something out of the box (or offline it)
>   *can be used it in "test" mode to see what it would add
>    if you ran it for real (in case you re-arranged your SCSI
>    cards),
>   *can use it on a chrooted set up to get the appropriate
>    devices on a mounted root file system for duplication,
>    flar, etc.
> And it works, unlike the previous set of commands where
> you pretty much *had* to reboot -r to get everything "noted"
> by the system.

Thanks for the details. I'm still not clear why devfsadm or disks
(assuming they are the same) worked, but cfgadm -c configure didn't. A
wild guess is that if I had done drvconfig after that it probably
would have shown up, versus I suspect cfgadm does it automagically if
the drive is already prepped for Solaris.


More information about the rescue mailing list