[rescue] Solaris 10 x86 hardware support

Andrew Weiss ajwdsp at cloud9.net
Thu Mar 3 08:45:07 CST 2005

Quoting "Curtis H. Wilbar Jr." <rescue at hawkmountain.net>:

> Anyone else here looking at Solaris 10 for x86 ?
> I haven't run Solaris x86 newer than Solaris 8 x86.
> What gives with the HCL ?
> Sun used to have a nice HCL.  An HCL you could have confidence
> in .... the one everywhere on there site seems to link to know
> is one that people submit to and seems to cover multiple
> versions ????
> ...
> Went to install it on a Proliant 1600... looks like they
> removed support for the Smart2 array controller in Solaris 10.
> Found a list of things removed... they also removed support
> for AMI MegaRAID and Mylex RAID controllers.
> ...
> I tried loading the Solaris 8 driver update disk from compaq
> but it fails to load the driver because it can't find a
> symbol (regarding EISA I'm guessing because of the symbol's
> name... which leads me to think the EISA support has been
> pulled possibly from 10 as well ? Not that I have any EISA
> systems to run 10 on anyway).

I tried to put a beta of Solaris 10 (very recent) on my Compaq Proliant
6400R.  I experienced the exact same problems... what you need to do is
go back to Solaris 9.  Solaris 9 will support all the systems that 8
did... find the Smart2 driver on the Solaris 8 floppy set (make it)...
then edit the directory name and one of the config files so that later
when it attempts to install the driver it doesn't bomb out...
(basically change the OS version to 59 or something rather than 58).

My 6400 has a Smart Array 4200 controller.

10 also seems to suck and not be worth it... you have to do a graphical
install on 10 vs. 9 you can boot straight to software 1


More information about the rescue mailing list