[rescue] Help -- My Netra-J eats ethernet interfaces!

Andrew Gaylard ag at computer.org
Wed Jul 20 02:34:41 CDT 2005

To add a few more details, I have a Netra-j system (which is, I
believe, very similar to the Ultra-2).  It's a 200MHz UltraSPARC
with SBUS slots.

When it was new, the only SBUS slot occupied was taken by a cgsix
board.  The system worked brilliantly for some years, until a major
thunderstorm, when the hme interface died completely.  (Apparently,
my country is the second worst in the world for lightning).

Anyway, my employer threw the box away on the advice of Sun's
service engineer, who I feel wasn't qualified to operate a power
switch, never mind wield a screwdriver.  So I gratefully took
the box.

I got a 501-2015 ("-05rev50") SCSI+le board, which worked
great for years.  Then it stopped.  At the same time, my ether
hub died a spectacular death (no idea how -- this time
there wasn't even any lightning around).  When I replaced the hub,
the link light came on, but Solaris wouldn't see the link was up.

Oh yes, the tests in the BootPROM all pass.

So then I got another 501-2015 ("-03rev50" this time) courtesy of
eBay, but it gave the same symptoms from the outset.  So I'm not
sure if the new board was DOA, or if my system has some serious
problem which will cause _any_ new board to fail to work.

Solaris has no problems seeing any of this hardware:  if I plug
in the CG6 board, a CG3 that was thrown my way, and both 501-2015s,
then both graphics boards, both SCSI interfaces, and both le
interfaces are seen by Solaris, and everything works, except for
the darn ether-link problem.  I can plumb the interface, set it
"up", ping myself, the works.  But I can't ping any of my other
systems, and they don't see any packets from the Sun.

Replacing the hub with a swap-over cable to another system showed
no traffic either, and my Intel laptop, HP PA-RISC box, and DEC
Alpha box are fine with the hub, so I don't think it's to blame.
Naturally I swapped out all cables, tried with and without the
tpe-link-test BootPROM option, etc., etc.

So I'm a bit cautious of buying a _third_ SCSI+le card, as you might

But I'm really keen not to throw away the box -- it works brilliantly

What should I do?  I see these as my options:

- Try one last time with a third 501-2015.
   This looks like a dumb idea (didn't I already do that?)

- Try one of the quad-fast-ether SBUS boards.
   These are expensive ($100!), but they are at least a different
   design,  and 100Mb/s would be nice.

- Give it up and throw away the box -- the Sun HW engineer was
   right after all.  Because it has now presided over the
   destruction of one hme interface and two le interfaces, it
   may well have caused their destruction.

Any other ideas?  Please, I'm desperate, and quite willing to
break out the soldering iron!


PS: Oh yes, if it makes any difference, this is with Solaris-9,
plus the "Recommended" patch bundle from January or February.

More information about the rescue mailing list