[rescue] SGI Crimson boot sequence?

Gerhard Lenerz mail at g-lenerz.de
Wed Jun 9 12:30:23 CDT 2004

Hello Francois & all other rescuers,

Monday, June 7, 2004, 11:15:59 PM, you wrote:

> I tried a Toshiba XM3501, an XM5301 (I couldn't find a setting for
> blocksize on either), a plextor PX-32TSi (with and without the "Block" 
> jumper on), a NEC Spin something 6x, and still always the same exact 
> error. I also put the CDROM on bus 0 and SCSI ID 4 just in case, 
> following on Francisco Javier Mesa-Martinez recommendation. No go.

  Very strange. The result is always exactly the same?

  Have you tried any of the drives on the other SCSI bus (dksc(0,x,y))
  so that we can rule out cabling/termination/fuse issues?

> Caleb also suggested:
>  >Have you tried "ls dksc(1,2,8)" and "ls dksc(1,2,7)" ?
> It complained it couldn't find ls (with some CDROM light activity just
> before the error).

  ls will only work in either IRIX or the standalone shell. To get
  that far you need a working CD-ROM. What happens if you specifically
  try to load something wrong from the volume header? Assuming your
  CD-ROM is on ID# 5 and bus# 1 doing "[boot [-f]]
  dksc(1,5,8)nonsense" shoud get you a listing of the files inside the
  volume header.

> As for Plextor, I know you are using one, but maybe only a specific
> model or even firmware will work. What is your model/rev?

  Good question. Currently I can only give you the model. I've used a
  32x Tray Plextor with *any* of my workstations (including IBM
  RS/6000, Sun Sparcstations and all reasonably new (as in "~1989")
  SGIs(*)). I also tried another Plextor 32x, Plextor 8x and Toshiba
  drive on a 4D/20 (classifies as pre-1989 in the above statement). I
  had luck with all Plextors on newer SGI hardware (like 4D/35).


(*) This includes Indigo, Indigo 2, Indy, 4D/240, 4D/420, 4D/25,
    4D/35 and Crimson. On the Octane it didn't work but I assume
    cabling issues (typical wide vs. narrow SCSI trouble).

More information about the rescue mailing list