[rescue] SGI Crimson boot sequence?

Francois Dion fdion at atriumwindows.com
Thu Jun 3 09:28:59 CDT 2004

Gerhard Lenerz wrote:

>  Hmmm... I think it's the PROM version that dictates the time. Can't
>  remember seeing anything else except dates from 1988-1990.

Yep the GM3 came from a Power series (amazing what you can find 
searching old usenet posts), so the date correspond. On the subject of 
PROM, the IP17 prom showed:
 >> version
PROM Monitor SGI Version 4.0.3  Rev IP 17, Apr 30, 1992
Just a tad over 12 years.

>  Ah, on the other hand VGX/VGXT doesn't make a big difference apart
>  from the "nice to have" value I guess.
Is OpenGL out of the question on either anyway?

> Getting 128MB instead of
>  256MB sucks a bit, if the machine was free or cheap enough that
>  isn't a problem either. It's enough for running IRIX 6.2.
Yes, but I have 2 machines and 1 with no memory... Looks like something 
I could find in my PC junkbox tough... I know we had a 4D/310 at 
Videoway that was OK with PC memory (9 chip tough, not the 8 chip variety).

>>Alright, let's try hinv:
>>               SCSI CDROM: Controller 1, ID 6
>  So it sees the CDROM, but not a drive. That there is no harddisk
>  attached is correct?
While I was doing the initial test, I didn't want to complicate things. 
I've since added a 4.5GB Cheetah in the bay below the CDROM and waa 
picked up by hinv.

>>Alright then, let's try to boot this sucker. Too bad I dont know how to 
>>set the output to the monitor instead of the console.
>  Enter the command monitor and try setting the console variable to
>  "g":
>  setenv console g

Sure enough it was set to d. put it on g, exit, power cycled and Yay! I 
got activity on the monitor and keyboard works!

>  If it is attached and you are still in the command monitor there is
>  a variable that shows GFX status. It is IIRC set to "(dead)" if
>  there is no graphics hardware and/or no keyboard/mouse detected.
 >> printenv

>  It is trying to boot from SCSI ID #2 for some reason. You could
>  either set the SCSI ID on the drive to #2 or have a look at the
>  NVRAM variables in the command monitor.

Now I did move the CDROM to ID 2.
Still no go (see my other post).
Going thru the PROM and typing boot dksc(1,2,8)sash.IP17 should do it 
tough, right? Or is -f required? When I get back home, I will try with 
the -f option. I'm still waiting on my high speed access at home, so 
internet access is not easy, else I would have tried that. I'm printing 
all the info from your website and putting it in a binder so I can refer 
to it at home.


More information about the rescue mailing list