[rescue] RS6k serial console tips?

Todd Carson tc+rescue at jc.dsl.telerama.com
Thu Apr 8 22:42:06 CDT 2004

I'm (still) trying to install AIX 5.1 on my RS/6000 model 250: now I can't get past the point where it asks for the system console (LED c31).

>From what I've read, I know that I can't select the graphics console here without an original IBM keyboard, which I don't have. I was under the impression, though, that I could select a serial console at this point. I haven't had much luck with this so far, though, and I was hoping people with more experience with RS/6000 hardware and AIX might have an idea of what's going on.

Here's how the system is behaving:

If I have a keyboard (a standard PC PS/2 keyboard, DEC-branded) plugged in, then the system will hang at LED c31 with no output to either the monitor or other machines connected to S1 or S2. Input to either the keyboard or the remote terminal emulators has no effect.

If the keyboard is not plugged in, then the "Select the system console" prompt is displayed on the monitor, but still nothing is output to either serial port S1 or S2, and typing things in from a serial connection "blind" doesn't accomplish anything.

The first few times I tried using a serial console, the machine would drop to the KDB prompt if I hit the reset button while it was sitting at LED c31, and I could use the kernel debugger over the serial line. If I use the "gcons" command to grab the console, then "g" to continue, then the system will reboot and I'll get one or two messages on the serial console as it boots, but I still wouldn't get the "select the console" prompt when it gets to LED c31. I haven't been able to do that the past few times I've tried, though.

Since I don't have the right cable to connect the RS/6000 to my U10 sitting right beneath it, I'm using a Mac Classic with Kermit. They're connected with a Sun-branded DB-25 to MiniDIN-8 cable ande a Radio Shack "null modem adapter". I'm assuming the cable and terminal settings (9600 8N1, DTR handshaking) are okay since I was able to use the kernel debugger. Maybe this is a bad assumption to make, I don't know.

Tomorrow I'm going to check the place where I got the machine to see if I can pick up a keyboard that would work, but I'm not optimistic. Does anyone have any ideas as to why this prompt isn't being displayed on the serial console and what I can do about it?

Todd Carson

More information about the rescue mailing list