[rescue] Hacking Linux since.....

Steve Hatle shatle at nfldinet.com
Fri Sep 26 08:15:57 CDT 2003

I still have my first Linux "distro" - Yggdrasil "Plug and Play" Linux from
Fall 1994.

Kernel 1.1
"Now includes universal DOS MSCDEX CDROM driver!"
Note: Diamond video cards not supported
Requires 4 MB of RAM and at least a 386 processor
All binaries without source come to 350 megabytes
Blah, Blah, Blah

We ran this on 386/20 AT&T WGS386 hardware as our first DNS, mail, and web
server in the spring of 1995. I bought it because it came with a CD, so I
didn't have to download a bunch of stuff.

If that company hadn't been bought out a while back, I'd bet there would
still be a box running this someplace. They weren't prone to fiddle with
things, especially after I left soon after it was implemented. I was "that
UNIX guy". <grin>

Case in point. I got called back a couple of years later as they were
rolling out a frame relay network to connect about 70 retail locations.
Previous data transfer between corp and the *nix based POS systems had all
been via UUCP over modems.

They realized that they had no time or bandwidth to rewrite all the file
movement scripts, etc. using any other protocols like ftp/rcp/you name it.
They liked how the UUCP implementation worked, but wanted to ditch the
modems. I fiddled with the Systems/Devices/Dialers files and got UUCP
working over ethernet- explaining to them that login/password handshake info
was going over in the clear. Since it was a private frame, they deemed it an
acceptable risk vs. the investment in doing the file transfer stuff all over
again. It actually worked pretty slick, though it was a major hack, in my
mind. I actually got a nice bonus on that one.

Ah- the good old days. <grin>


P.S. I am employed. Still in IT, but thankfully not dealing with UUCP
troubleshooting anymore. I think I've finally forgotten the syntax of the
Systems/Devices/Dialers files after 10 years.

More information about the rescue mailing list