[rescue] wanted: diskimage for sun3 architecture

Curtis H. Wilbar Jr. rescue at hawkmountain.net
Tue Oct 14 17:29:47 CDT 2003

On Tue, 2003-10-14 at 15:57, Walter Belgers wrote:
> Hi all,
> I am trying to get my Sun 3/60 to work and encoutered some problems. It
> would be really helpfull it somebody could provide me with a diskimage
> of a working system (preferably SUN0105, SUN0424 or SUN1.05G).
> Long version:
> I got two 3/60s, one of which has no working SCSI (or so does the label
> on it say). 
> 1) First I wanted to boot the oldest SunOS I could find. I took SunOS
> 3.5 from sunarc.org and tried to netboot it. It kind of works, until the
> kernel starts trying to mount partitions via the network disk protocol.
> Although NetBSD's Matt Fredette has written a ND daemon, it does only
> support booting via ND, not mounting. (I succesfully use it to netboot
> my Sun 2/50.)

How does the Sun 2/50 then mount partitions ?  (or were you using
SunOS 5 on the 2/50 and using NFS to mount parittions) ?

> 2) Then I tried netbooting SunOS 4.0.3. I couldn't find the correct
> kernel between all the seperate tape image files, so I put in a SunOS
> 4.1.3 kernel with the 4.0.3 userland. The kernel loads and probes the
> devices, then does a NFS getattr on the swap and then hangs.

There was no SunOS 4.1.3 kernel for Sun3.  Sun stopped support for Sun3
at SunOS 4.1.1_U1 (or was it 3x that stopped at 4.1.1_U1 and straight
Sun3 at 4.1.1 Rev B ?).

> 3) After this I tried soldering a harddisk in the system using the HOWTO
> on sunstuff.org. The Sun 3/60 motherboard has places reserved to solder
> in a SCSI connector and a power connector. The 4 wires of the power
> connector have +5 and GND, but there's no +12V... Also not on my
> spare-parts-Sun3/60. Weird. So this doesn't work, without +12V the disk
> won't spin up.

possibly a fuse ?  maybe some boards didn't have everything required to
make that work... dunno as I don't have a 3/60.

> 4) I connected an external disk (SUN0424) (luckily I have a SCSI cable
> that goes from the really-old connector with 3 rows of pins to something
> more modern) and a QIC-150 tape. I have original 4.1 SUNBIN tapes for
> Sun3. I checked the tapes, there's still okay. Booting wouldn't work
> though. Found out via sun3arc that I had a PROM that was too old (1.9).
> 5) Took the PROM from the spare-parts-sun3/60 (2.8 or something) that
> supports QIC-150 drives. And yes, I can do a b st() and a st(0,0,2) to
> get standalone copy. But.. it doesn't copy stuff to the disk. The disk
> activity LED flashes briefly, nothing else happens. The disk is SCSI id
> 0. I also tried b st()install st(0,0,4) which loads a kernel that does a
> device probe, following by the tape drive whirring, followed by a hard
> reset of the system. The problem is not the disk, nor is it the SCSI
> cables.

Your hard disk to install on should be target 3.  SunOS oddly maps
sd0 to target 3, etc... (if you have any running SunOS system that
hasn't beem modified look at the kernel conf file you will see the
sd and st to id mappeings in there.... it's the same for most if not
all SunOS 4.X releases).

Another thing to keep in mind... is sometimes you can't just 'plop'
newer boot roms into a board.... sometimes there are ECOs required
(like with the Sun 3/80 going to 3.03 ROMs).

> I'm getting fed up :) but won't be defeated.
> Walter.

Good luck,

  -- Curt

More information about the rescue mailing list