[rescue] Anybody remember MFM? (Durango Poppy II problem)

Walter Belgers walter+rescue at belgers.com
Tue Aug 5 11:10:05 CDT 2003

Hi all,

A few months ago I mailed about my Durango Poppy II 80286/80287 MS-Xenix
system that I could not get to boot because of the QD (Quad Density)
5.25" drive.

I tried the bootfloppies (that had many read errors) again and lo and
behold, they suddenly work (maybe because it's so hot at the moment).
Xenix 3.1f+ Upgrade+ boots into a single-user shell.

Now the problem: although the Micropolis 1325 71MB MFM drive spins up, I
cannot read/write it, I get an error on the first block. I do have the
correct /dev entry: the HD drive LED goes on. I tried inserting another
(21MB) MFM drive with the same problem.

The drive is connected to a board from 'Molecular Systems' which has 3
connectors: 2 for the MFM drive and a 50 pin connector. I am hesitant to
try out if it's SCSI. Were combined MFM/SCSI cards normal in the old

Also, there are two potentiometers (is that English? variable resistors)
that are next to the MFM connectors. Would fiddling with those improve
my chances of getting this thing to work?

Walter Belgers         "Si hoc signum legere potes, operis boni in rebus
walter at belgers.com       Latinis alacribus et fructuosis potiri potes!" 

More information about the rescue mailing list