[rescue] Installing OpenBSD on a Sparc2

Simeon Johnston rescue at sunhelp.org
Tue Jun 12 09:18:54 CDT 2001

Sorry for the long post.

> you are using a null-modem cable between your mac and your sparc,
> correct?  default is 9600,8,n,1 or 9600,7,e,1 for console (i forget
> exactly
> which it is)

The cable is correct.  I use it on a SPARCstation 10 so I know that
isn't the problem.

> 9.6/8N1 should be right.  Keep in mind that you're talking first to
> the firmware, then to a tty device.  Once you get going, you may have
> to change to 7E1 in midstream.  I know SunOS 4.1.x will bite you
> that way....

No OS on the HD.  I got this off a running SPARCstation 20 that was
using it as storage space and low level formated it.
Completely cleaned off.

> >>Should I pull the video card also?
>  I would recommend pulling it.
> BTW, we call them frame buffers around here.

I pulled the frame buffer and the other card (some kind of expansion for
Ethernet, serial and scsi all in one) and still got nothing.

> Issues to consider:
> 1. If you have installed 501-1739 Sun barcoded simms in all 16 slots,
> ski=
> p to
> #2, otherwise:
> The SS2 has a non-standard simm bank pattern, unlike the SS1+.  If you
> do=
> n't
> have all the slots
> filled, and you were not aware of this and/or you don't happen to have
> se=
> ction
> 4 of the service manual
> handy, email me and I will help you figure out the proper locations.
> The
> machine won't boot
> at all if it isn't happy with its ram.

The ram is the same as it was when this thing was shutdown for storage
(so I've been told).

############      ############
| RAM                   | RAM
| RAM                   | RAM
| NO RAM            | NO RAM
| NO RAM            | NO RAM
| RAM                   | RAM
| RAM                   | RAM
| NO RAM            | NO RAM
| NO RAM            | NO RAM
############      ############

Which I beleive is correct.  I seem to remember some sort of interlaced

> SPARCstation 2 has an on-board CPU on the main board, and except for
> the
> Weitek Power-UP upgrade, it's not upgradable. May be a TI chip or even
> Fujitsu or Weitek I think. It's fairly likely that you do have a CPU,
> although I wouldn't bet my rabbit on it.
> The slots you see are SBUS, not MBUS. MBUS is what the CPUs go into on
> SS10/20/600/1000. Usually a white connector with a blade, if I recall
> correctly, as opposed to the black almost-wide-SCSI-looking connector
> for

Thanks, I was confused about that.  I'm sure the CPU is there now.  No
missing parts on the MB that I can see.

> I know this may not help a lot, but the SS2 I have running OpenBSD 2.5
> installed fine from serial console, no magic or sacrifices. It's also
> run
> SunOS 4.1.4, Solaris 2.5.1, and Redhat 4.2, almost never with a
> monitor or
> keyboard. I think it does have a cgsix as well as the boris+natasha
> memory
> card, but I don't remember about the frame buffer. I haven't seen the
> back
> side of it since I moved in two years ago :)

I'm sure it will work if I could ever get the OS installed.
BTW, the SS2 can boot from cdrom, right?  If it can't I'm kinda screwed
anyway.  No floppy that works.

> Is there a way for you get in and see what your OpenBoot settings are?

> someone might have left the serial ports set to something other than
> standard settings you are using. Do you have a monitor to see what it
> while booting?

No monitor.  We have no monitor and no adapter.
Someone threw out the old monitor (not a great loss.  I think it was a
12" or 13" monitor)
Not really any possibility for a monitor in the near future.

> Are you certain you have a null modem cable?


> I have also had a problem with getting suns to talk to macs over the
> port. Particularly the IPX.
> On the ss2 (like the IPX) there are a pair of jumpers to set the
serial port
> protocol from rs232 to rs423. this may help. Check the Sun Hardware
> Reference for details.

I just found them.  Would it matter if they were both off?
I set the rs232 jumper and will test that hopefully sometime today.

> IIRC Geoport compatible serial ports are supposed to be rs232/422
> compatible. So, try making sure the jumpers are set to rs232.
> On the IPX which has a similar setup, I have tried both jumper
> Neither of them worked. The same IPX comes up just fine connected to a
> serial port. :-/

If I can get minicom to work on my Linux laptop (also a POS) than I can
try that also.

> Other than that I have not had any problems getting an ss2 to output
> to my mac, a PowerCenter Pro 240.

I'm using a Beige G3.  I used this computer with the SS10 without

Is there a way to restore the PROM settings to factory default?  Just in
case that's the problem I would like to eliminate some possibilities.
Will this cause even more problems than it's worth?  I kinda doubt it.

Thank you all for your help.  I have several leads as to what the
problem is now and will check them all out.


More information about the rescue mailing list