[rescue] HELP: LX stuffed

Robert Rose rescue at sunhelp.org
Tue Jun 12 07:18:43 CDT 2001

Hey all,

I've dug out an LX that was working a couple of months ago and is now 
stuffed, I thought I'd run the list of things I've done to date past 
everyone and see if we can't make some progress.

Initial specs: Sparc LX, 2 x 16Mb SIMMS, 1Gb IBM internal scsi disk, 
internal floppy poached from an IPC, no keyboard or monitor attached, using 
ttya for input and output.

Day 1. Internal disk appears stuffed, probe-scsi shows:
Target 0

so I swapped out the disk for a known good one, same symptoms.  Pull the 
case apart again, stare at it and mumble a bit and give up for the night.

Day 2. Thought I'd try again, guess what, probe-scsi shows the disk just 
fine.  Great, power off, attach external CD-Rom, shove in OpenBSD cd and 
power everything back on.  Attempt to boot from the cd and I get:
Trap # (hex) be

WTF?!, so I try probe-scsi:
Target 0
Target 6

Damn, SCSI bus must be having problems, power off & on everything to see if 
it will help.  On power on I get:

Warning: Fcode sequence resulted in a net stack depth change of 128

before the usual banner.  Still no joy in booting, same problem as 
before.  Pull case apart again, stare & swear and give up for the night.

Day 3. Dig out an FSBE to try thinking the internal SCSI bus must be 
*ucked.  Unplug internal SCSI disk, stick in FSBE, attach external 1Gb Sun 
disk & CD to the FSBE, power it all up.  A probe-scsi showed all was well, 
set a new devalias for cdrom1 and try and boot from CD.
Trap # (hex) be

grrr, power off, swap in another spare FSBE, check cables, eject OpenBSD cd 
and try a trusty Solaris 2.6 cd, same result.
Trap # (hex) be

No, *NOT* ok !  Not happy Jan!!

and that's the state I'm in at the moment.  I can occasionally get the 
thing to probe-scsi on the internal bus and show up the correct targets, 
but it just won't boot.  I haven't tried net-booting it yet, if there are 
no good ideas from the list members in the next few days I'll try it.  It's 
not going to be much good to me if I can _only_ use it diskless, so I'd 
really like to get this SCSI problem sorted.  Apart from the LX, the rest 
of the bits (CD, other SCSI disks, OpenBSD cd, SCSI cables) have been 
proven to work ok on the IPC I built last weekend, so they're not the culprit.

Thanks for letting me vent some frustration and I apologise if this has 
been a bit long, but I really am stumped.  Any suggestions or advice would 
really be appreciated.



More information about the rescue mailing list