[SunRescue] Continuing foibles of Tim and SGI

MarkDaviesMarkUK at uunix.demon.co.uk MarkDaviesMarkUK at uunix.demon.co.uk
Sun Sep 17 16:01:24 CDT 2000

Tim Harrison wrote:

> My problem is this:  I can't mount the .iso file, like I would under
> Linux.  I can netboot to my heart's content, but I can't install off of
> an image that won't mount somewhere.  IRIX 5.2 (yes, I did say 5.2 --
> hey, why do you think I'm trying to find ways to install? :) ) doesn't
> have some kind of loop device (a la /dev/loop0 under Linux) that I can
> use as a block device to mount from.
> All I need to do is mount the ISO, and I can install away like mad.  But
> therein lies the problem.
> Any ideas?

Hi Tim.

You may want to e-mail of-list, because, atm I don't quite understand
what's happening. This is how I see it:
If you've just ftp a file to IRIX 5.2 then the file is stored in a EFS
system state. Am I right so far?

One of the problems, which I'm sure you are aware of is, if a set of
file and subfiles goes through a windows machine, then some of the
filenames are lost: eg:     /usr/filesystem get overwritten with
/usr/FILESYSTEM, I have a CD Image of IRIX 6.5 that this has happend to,
and will not work at all. But I think I'm going off track here. Anyway
one other idea, before you explain exactly were you are with this, is:
have you tried wiping out the drive and installing it into the INDY. The
OS won't boot if the INDIGO is an R3 but you may well be able to issue
something like:    boot -f dksc(0,X,X)sashARCS dksc(0,X,X)stand/fx.ARCS

the first x is the id of the drive.
The second X is the partion)
Third X is again the drive ID
Fourth X is normally 1 less than the 2nd number.

OR have you tried on the INDY : INSTALL
Select Remote Directory
Enter the ip address (or name) of your INDIGO
Enter the directory you have the files stored in:

These are just ideas atm, because I'm not fully understanding were you
are at. But I will say that, if you've copied the files to the INDIGO,
then the filesystem is already mounted (on the INDIGO) if you are trying
to mount the filesystem on the INDY to install... well.. it just doesn't
work like that. You don't need to mount. boot will do it for you.

Sorry if I've not understood you Tim and wasted your time etc, but I'm
willing to help you, but you'll have to explain in detail what you have
done etc...  Maybe the Atalnatic ocean is causing some dumbness on my

Look forward to hearing from you.

More information about the rescue mailing list